summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSughosha <[email protected]>2025-02-21 14:31:59 +0530
committerMaxim Cournoyer <[email protected]>2025-02-22 23:55:24 +0900
commit4da2e97ffe422e0253da46c70d9e4ff4831ea8b3 (patch)
tree668775f8808a440a9114c623ad79350640e54706 /gnu
parentf40949fe7569eb13466a65fedd83b8429c49b69b (diff)
gnu: Add qtwidgetanimationframework.
* gnu/packages/qt.scm (qtwidgetanimationframework): New variable. Change-Id: I0368d1b68d80b64b9d363b5e76c3133619b3ccaa
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 81d26e0a1c..13893d2951 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2024 Foundation Devices, Inc. <[email protected]>
;;; Copyright © 2024 Josep Bigorra <[email protected]>
;;; Copyright © 2025 John Kehayias <[email protected]>
+;;; Copyright © 2024 Sughosha <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4988,6 +4989,66 @@ window docking system.")
programming paradigm.")
(license license:expat)))
+(define-public qtwidgetanimationframework
+ (let ((commit "b07ab59cee7a21eb29d29cb67c160681f13ac5ae") ;no tags
+ (revision "0"))
+ (package
+ (name "qtwidgetanimationframework")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/dimkanovikov/WidgetAnimationFramework")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1smbdrzk05vvbf6lpjdq82k4y2kc4yv1gk5388qbslbzlb6ihls6"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:qtbase qtbase
+ #:tests? #f ;no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; This project does not have any build rule but its demo has
+ ;; one.
+ (add-after 'unpack 'pre-configure
+ (lambda _
+ (copy-file "demo/waf-demo.pro" "src/waf.pro")
+ (substitute* "src/waf.pro"
+ (("main.cpp ") "")
+ (("app") "lib")
+ (("waf-demo") "waf"))
+ (chdir "src")))
+ ;; No configure script exists.
+ (replace 'configure
+ (lambda _
+ (invoke "qmake")))
+ ;; No install rule exists.
+ (replace 'install
+ (lambda _
+ ;; Install library files.
+ (for-each
+ (lambda (file)
+ (install-file file
+ (string-append #$output "/lib/"
+ (dirname file))))
+ (find-files "." "\\.so"))
+ ;; Install header files.
+ (for-each
+ (lambda (file)
+ (install-file file
+ (string-append #$output "/include/WAF/"
+ (dirname file))))
+ (find-files "." "\\.h$")))))))
+ (home-page "https://github.com/dimkanovikov/WidgetAnimationFramework")
+ (synopsis "Extension for animating Qt widgets")
+ (description
+ "@acronym{WAF,Widget Animation Framework} is an extension for animating
+Qt widgets.")
+ (license license:lgpl3+))))
+
(define-public qtcolorwidgets
(package
(name "qtcolorwidgets")