summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSughosha <[email protected]>2025-02-21 14:31:58 +0530
committerMaxim Cournoyer <[email protected]>2025-02-22 23:55:24 +0900
commitf40949fe7569eb13466a65fedd83b8429c49b69b (patch)
tree5bba0b6a02797945b2792d4538e21e62c63ec1e3 /gnu
parentd7eb32d2ca9290aba25033df42d730e034cfc74d (diff)
gnu: Add qtpromise.
* gnu/packages/qt.scm (qtpromise): New variable. Change-Id: Iaec93f91e8efe2a17eb32f7205f12eab5ed1e269 Modified-by: Maxim Cournoyer <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 7a95da037d..81d26e0a1c 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4948,6 +4948,46 @@ a binding language:
window docking system.")
(license license:lgpl2.1+)))
+(define-public qtpromise
+ (package
+ (name "qtpromise")
+ (version "0.7.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/simonbrunel/qtpromise")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nsh6v5k4kdrrhcd6adz947n0dka4rrbx8f8rvm1175545nbi67s"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:test-target "tests"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'fix-include-path
+ (lambda _
+ (chdir "../source")
+ (substitute* "../source/include/QtPromise"
+ (("../src/") ""))))
+ (replace 'install
+ (lambda _
+ (let ((include (string-append #$output "/include")))
+ (with-directory-excursion "../source"
+ (install-file "include/QtPromise"
+ (string-append include))
+ (copy-recursively "src/qtpromise"
+ (string-append include
+ "/qtpromise")))))))))
+ (home-page "https://qtpromise.netlify.app/")
+ (synopsis "Promises/A+ implementation for Qt/C++")
+ (description
+ "This package provides a Qt/C++ implementation of
+@url{Promises/A+,https://promisesaplus.com/} standard for the ``promises''
+programming paradigm.")
+ (license license:expat)))
+
(define-public qtcolorwidgets
(package
(name "qtcolorwidgets")