summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-03-08 08:48:51 +0000
committerSharlatan Hellseher <[email protected]>2025-03-08 08:49:39 +0000
commit0509134547207c28722528ac7052b2c9bc47e964 (patch)
tree12b093b540b32b7e51c1c2e08fc4bca3a71ba83b /gnu/packages
parent1260a3c0a832d540eef69c09f9efbf7c461740ff (diff)
gnu: Add python-nestle.
* gnu/packages/statistics.scm (python-nestle): New variable. Change-Id: Ic39bd9bc048007935e52898900effc65a4c55b7d
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 3febd29ee3..ba897fbb0d 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2023 Troy Figiel <[email protected]>
;;; Copyright © 2024 Vinicius Monego <[email protected]>
;;; Copyright © 2024 Nicolas Graves <[email protected]>
-;;; Copyright © 2024 Sharlatan Hellseher <[email protected]>
+;;; Copyright © 2024-2025 Sharlatan Hellseher <[email protected]>
;;; Copyright © 2025 Jonas Freimuth <[email protected]>
;;;
;;; This file is part of GNU Guix.
@@ -2339,6 +2339,32 @@ point (up to 50% contamination) and have a number of nice applications in
machine learning, computer vision, and high-dimensional statistics.")
(license license:asl2.0)))
+(define-public python-nestle
+ (package
+ (name "python-nestle")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nestle" version))
+ (sha256
+ (base32 "0v94qcqwl519vqhd4wb1zhx4x4q9xhbck8g2h0v2n4mwxgz9irsx"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; no tests in PyPI or Git
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-numpy))
+ (home-page "https://github.com/kbarbary/nestle")
+ (synopsis "Nested sampling algorithms for evaluating Bayesian evidence")
+ (description
+ "This package provides an implementation of
+@url{https://en.wikipedia.org/wiki/Nested_sampling_algorithm, Nested Sampling}
+algorithms for evaluating Bayesian evidence.")
+ (license license:expat)))
+
(define-public python-arviz
(package
(name "python-arviz")