summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-03-08 08:33:03 +0000
committerSharlatan Hellseher <[email protected]>2025-03-08 08:37:42 +0000
commit1260a3c0a832d540eef69c09f9efbf7c461740ff (patch)
tree0fd5d59c509bdc1f27843b9c103f43419296d17d /gnu/packages
parent3bb2ba0f182ead1015c80a3ec2663a7af737bf9a (diff)
gnu: Add python-line-profiler.
* gnu/packages/python-check.scm (python-line-profiler): New variable. Change-Id: Ia1187c2bdf56d1da86756997cbd02808735c905d
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-check.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 0beec6267d..e76f2950a2 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -575,6 +575,41 @@ Built-in integration with @url{http://nedbatchelder.com/code/coverage/, coverage
@end table")
(license license:expat)))
+(define-public python-line-profiler
+ (package
+ (name "python-line-profiler")
+ (version "4.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "line_profiler" version))
+ (sha256
+ (base32 "15hs8pmv7pcilnhhp0l5pamjihmh7zlnvvpsnf046lbnz0jhzq89"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; XXX: Test can't compare the versions: AssertionError: Version
+ ;; Mismatch: kernprof and line_profiler must be in
+ ;; sync. kernprof.line_profiler = . kernprof.__version__ = 4.2.0.
+ #~(list "--deselect=tests/test_cli.py::test_version_agreement")))
+ (native-inputs
+ (list python-cython-3
+ python-pytest
+ python-setuptools
+ python-ubelt
+ python-wheel
+ python-xdoctest))
+ (home-page "https://github.com/pyutils/line_profiler")
+ (synopsis "Line-by-line profiler for Python")
+ (description
+ "This package provides @code{line_profiler} - a Python module for doing
+line-by-line profiling of functions. @code{kernprof} is a convenient script
+for running either @code{line_profiler} or the Python standard library's
+cProfile or profile modules, depending on what is available. It's a
+successor of @url{https://github.com/rkern/line_profiler}.")
+ (license license:bsd-3)))
+
(define-public python-pytest-click
(package
(name "python-pytest-click")