summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/emacs-disable-jit-compilation.patch
diff options
context:
space:
mode:
authorLiliana Marie Prikler <[email protected]>2024-02-13 19:30:50 +0100
committerLiliana Marie Prikler <[email protected]>2024-02-24 08:08:31 +0100
commit3621493e4cc9f83253d7f191b783fd11212c7045 (patch)
treee548b7f260eb4de761433213eb7c13cb124b9139 /gnu/packages/patches/emacs-disable-jit-compilation.patch
parent35fc3027f372eddbd21a2c6b5a591453591a6825 (diff)
gnu: emacs: Disable jit compilation.
* gnu/packages/patches/emacs-disable-jit-compilation.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/emacs.scm (emacs-minimal)[patches]: Use it here.
Diffstat (limited to 'gnu/packages/patches/emacs-disable-jit-compilation.patch')
-rw-r--r--gnu/packages/patches/emacs-disable-jit-compilation.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-disable-jit-compilation.patch b/gnu/packages/patches/emacs-disable-jit-compilation.patch
new file mode 100644
index 0000000000..8b1ac5a9df
--- /dev/null
+++ b/gnu/packages/patches/emacs-disable-jit-compilation.patch
@@ -0,0 +1,19 @@
+Index: emacs-29.2/src/comp.c
+===================================================================
+--- emacs-29.2.orig/src/comp.c
++++ emacs-29.2/src/comp.c
+@@ -5648,8 +5648,12 @@ For internal use. */);
+ doc: /* If non-nil, compile loaded .elc files asynchronously.
+
+ After compilation, each function definition is updated to use the
+-natively-compiled one. */);
+- native_comp_jit_compilation = true;
++natively-compiled one. This variable is enabled by default upstream,
++but disabled in Guix to better make use of precompiled packages.
++Notably, Guix removes the hashes that prevent inadvertent shadowing
++frm the file names of compiled libraries in order to facilitate grafts.
++Enable at your own risk! */);
++ native_comp_jit_compilation = false;
+
+ DEFSYM (Qnative_comp_speed, "native-comp-speed");
+ DEFSYM (Qnative_comp_debug, "native-comp-debug");