summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-12 17:04:36 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:48:01 +0000
commit3998babb63cfe4227dec54ba9527dddd5be81eea (patch)
treea6e27e2b1b2e548a801b3f6ecf03af91fe6c85a7 /gnu/packages/golang-web.scm
parent00b06100448870dd008368b5a88ca4e0180d5dd7 (diff)
gnu: Add go-github-com-babolivier-go-doh-client.
* gnu/packages/golang-web.scm (go-github-com-babolivier-go-doh-client): New variable. Change-Id: I332d6e7cc5b9b1502c24d95ad2a06164181e324d
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index e64aa9f27d..5e08bc3941 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -989,6 +989,41 @@ the OTEL Go SDK.")
Manager,NTLM}/Negotiate authentication over HTTP.")
(license license:expat)))
+(define-public go-github-com-babolivier-go-doh-client
+ (package
+ (name "go-github-com-babolivier-go-doh-client")
+ (version "0.0.0-20201028162107-a76cff4cb8b6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/babolivier/go-doh-client")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ca72jz5d5wf5hkcjiwrjvh4fp9p0nqhgwyx9p3vq9sdrx524d21"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/babolivier/go-doh-client"))
+ (home-page "https://github.com/babolivier/go-doh-client")
+ (synopsis "DNS over HTTPS client implementation written in Golang")
+ (description
+ "Package doh implements client operations for @code{DoH} (DNS over HTTPS)
+lookups. It implements looking up the following records:
+@itemize
+@item A
+@item AAAA
+@item CNAME
+@item MX
+@item NS
+@item TXT
+@item SRV
+@item SOA
+@item PTR
+@end itemize")
+ (license license:gpl3)))
+
(define-public go-github-com-beevik-ntp
(package
(name "go-github-com-beevik-ntp")