summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-12 11:24:05 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:48:01 +0000
commit00b06100448870dd008368b5a88ca4e0180d5dd7 (patch)
tree7bc8e9048d7f23c1f85a2de09f94acaaaa915bb4 /gnu/packages/golang-web.scm
parentc710002f1ca8ee31404b204c5619d2589c391ce9 (diff)
gnu: go-github-com-quic-go-quic-go: Adjust tests.
Tests fail in CI as seen in <https://ci.guix.gnu.org/build/7688366/log/raw>. * gnu/packages/golang-web.scm (go-github-com-quic-go-quic-go) [phases] {check}: Adjust gingo options as tests fail in CI but passed when tested locally on 16 threads machine. Remove randomization, add logic to set "--proc" option. Change-Id: I25be422622cbab20f2eeb7c8200e20ab9491cf44
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index e82cc9cf15..e64aa9f27d 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -7035,11 +7035,16 @@ the Go standard library}.")
(lambda* (#:key tests? import-path #:allow-other-keys)
(when tests?
(with-directory-excursion (string-append "src/" import-path)
- (invoke "ginkgo" "-r" "-v"
+ (setenv "TIMESCALE_FACTOR" "10")
+ (invoke "ginkgo" "-r" "-v" "--no-color"
(string-append
- "--procs=" (number->string (parallel-job-count)))
- "--randomize-all"
- "--randomize-suites"
+ "--procs=" (number->string
+ ;; All tests passed on 16 threads
+ ;; mathine, but fail on
+ ;; ci.guix.gnu.org.
+ (if (> (parallel-job-count) 17)
+ 16
+ (parallel-job-count))))
"--skip-package=integrationtests"))))))))
(native-inputs
(list go-ginkgo