summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-27 11:34:49 +0000
committerSharlatan Hellseher <[email protected]>2025-01-27 11:38:42 +0000
commitf6687e700b5ec0bd50020d72df2ab3faf4e8679d (patch)
tree449e91f41b0fb41dbdfa7545f1d61c09ed0f5fa1
parent77603927fba0edc2c4d9de122aa132b968a051e5 (diff)
gnu: go-github-com-zclconf-go-cty: Skip some tests on non 64bit arch.
As seen in <https://ci.guix.gnu.org/build/8739612/log/raw>, 2 tests failed on i686-linux, where all passed on x86_64-linux. These changes skip some tests on non 64bit architectures. * gnu/packages/golang-xyz.scm (go-github-com-zclconf-go-cty) [arguments] <test-flags>: Conditionally skip some tests on non 64bit architectures. Change-Id: Ib9c50f297744d0fe4b6f40811fdeeeb2d22a361d
-rw-r--r--gnu/packages/golang-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 60321ace58..f2d58bbb99 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -15819,7 +15819,11 @@ Go host programs.")
(arguments
(list
#:skip-build? #t
- #:import-path "github.com/zclconf/go-cty"))
+ #:import-path "github.com/zclconf/go-cty"
+ #:test-flags
+ ;; Tests fail on non 64bit systems: unexpected error: invalid index:
+ ;; value must be a whole number, between -2147483648 and 2147483647.
+ #~(list #$@(if (not (target-64bit?)) '("-skip" "TestElement") '()))))
(native-inputs
(list go-github-com-google-go-cmp))
(propagated-inputs