summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 60321ace58..f2d58bbb99 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -15819,7 +15819,11 @@ Go host programs.")
(arguments
(list
#:skip-build? #t
- #:import-path "github.com/zclconf/go-cty"))
+ #:import-path "github.com/zclconf/go-cty"
+ #:test-flags
+ ;; Tests fail on non 64bit systems: unexpected error: invalid index:
+ ;; value must be a whole number, between -2147483648 and 2147483647.
+ #~(list #$@(if (not (target-64bit?)) '("-skip" "TestElement") '()))))
(native-inputs
(list go-github-com-google-go-cmp))
(propagated-inputs