summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCayetano Santos <[email protected]>2025-02-28 16:11:40 +0100
committerChristopher Baines <[email protected]>2025-03-01 22:22:35 +0000
commitde3954341b36325a6f908bd028d6cc379e9f26d2 (patch)
tree128f4875e0f593f7725a19a279c39b8238419f86
parentb9d183e567edf147fd3fc63630fadb149825ba20 (diff)
gnu: Add python-find-libpython.
* gnu/packages/python-xyz.scm (python-find-libpython): New variable. Change-Id: I167f640549a0baca5b378ddb84d33b12d71e2d9a Signed-off-by: Christopher Baines <[email protected]>
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c15671b53f..b8fd89ef39 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -162,6 +162,7 @@
;;; Copyright © 2025 Jordan Moore <[email protected]>
;;; Copyright © 2025 Dariqq <[email protected]>
;;; Copyright © 2025 Nguyễn Gia Phong <[email protected]>
+;;; Copyright © 2025, Cayetano Santos <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23338,6 +23339,31 @@ capable of parsing almost any programming language out there, and to
some degree most natural languages too.")
(license license:expat)))
+(define-public python-find-libpython
+ (package
+ (name "python-find-libpython")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ktbarrett/find_libpython")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z1r9nix2z75sv41j97pnl6jgj2lk6k8la23vavxjpprsc9ld1dd"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wheel
+ ;; tests
+ python-pytest))
+ (home-page "https://github.com/ktbarrett/find_libpython")
+ (synopsis "Find the path to the @code{libpython} dynamic library")
+ (description
+ "@code{find_libpython} helps find the path to the
+@code{libpython} dynamic library for the current Python environment. It is
+both a script and a Python package.")
+ (license license:expat)))
+
(define-public python-libcst
(package
(name "python-libcst")