summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSpencer King <[email protected]>2025-02-14 17:20:25 -0600
committerChristopher Baines <[email protected]>2025-03-01 22:22:35 +0000
commitb9d183e567edf147fd3fc63630fadb149825ba20 (patch)
tree54c675b35355ec002529bcbd6b65cd386b2d41c8
parent38011da03d13a3d4c436d01517186b6df34ad49e (diff)
gnu: Add r-randomforestexplainer.
* gnu/packages/cran.scm (r-randomforestexplainer): New variable. Change-Id: I9236716971219c55850440f8cbae022f5641eebc Signed-off-by: Christopher Baines <[email protected]>
-rw-r--r--gnu/packages/cran.scm38
1 files changed, 37 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a3898e54ef..2bb9649ab4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -38,7 +38,7 @@
;;; Copyright © 2022-2024 Navid Afkhami <[email protected]>
;;; Copyright © 2022 Greg Hogan <[email protected]>
;;; Copyright © 2024 Marco Baggio <[email protected]>
-;;; Copyright © 2024 Spencer King <[email protected]>
+;;; Copyright © 2024, 2025 Spencer King <[email protected]>
;;; Copyright © 2024 Tor-björn Claesson <[email protected]>
;;;
;;; This file is part of GNU Guix.
@@ -44025,6 +44025,42 @@ Analysis Toolkit (GATK) to load tables and plot data. The GATK is a toolkit
for variant discovery in high-throughput sequencing data.")
(license license:expat)))
+(define-public r-randomforestexplainer
+ (package
+ (name "r-randomforestexplainer")
+ (version "0.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "randomForestExplainer" version))
+ (sha256
+ (base32 "1ny8c3vn2zvdx12avwvlm4lp648jigkrkcvnhf5qmj8rh0w069v0"))))
+ (properties `((upstream-name . "randomForestExplainer")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-data-table
+ r-dplyr
+ r-dt
+ r-ggally
+ r-ggplot2
+ r-ggrepel
+ r-randomforest
+ r-ranger
+ r-reshape2
+ r-rmarkdown))
+ (native-inputs (list r-knitr r-testthat))
+ (home-page "https://github.com/ModelOriented/randomForestExplainer")
+ (synopsis
+ "Explaining and Visualizing Random Forests in Terms of Variable Importance")
+ (description
+ "This package provides a set of tools to help explain which variables are most
+important in a random forests. Various variable importance measures are
+calculated and visualized in different settings in order to get an idea on how
+their importance changes depending on our criteria (Hemant Ishwaran and Udaya B.
+Kogalur and Eiran Z. Gorodeski and Andy J. Minn and Michael S. Lauer (2010)
+<doi:10.1198/jasa.2009.tm08622>, Leo Breiman (2001)
+<doi:10.1023/A:1010933404324>).")
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public r-randomforestsrc
(package
(name "r-randomforestsrc")