summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-03 23:25:06 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:35 +0100
commitaeef83b53ddb620016b5b73a5f992a385d064aef (patch)
treed64413e561ea3c8fc97b7851f8dcd9b56ea301fe
parent821576544c55924fed59ea8fd1da3c422351a450 (diff)
gnu: python-pydantic-settings: Update to 2.7.1.
* gnu/packages/python-xyz.scm (python-pydantic-settings): Update to 2.7.1. [arguments]: Ignore tests from test_docs.py. [propagated-inputs]: Remove python-pyaml and python-tomli. Change-Id: Ie43e098c1a7787923a3cc92313832089b835a986
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b701336d23..27b205e645 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8579,13 +8579,13 @@ Interfaces} via data models provided in the JSON format.")
(define-public python-pydantic-settings
(package
(name "python-pydantic-settings")
- (version "2.2.1")
+ (version "2.7.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pydantic_settings" version))
(sha256
- (base32 "1vf58f398ngk6wpf0jn51ghw65mjs3m03yn06h25jlsmx6jzdf80"))))
+ (base32 "14zcbl32m53zfh054bkqk4jcjp72q1wa0w5z5wygnjz66nnwmj8h"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -8607,7 +8607,8 @@ Interfaces} via data models provided in the JSON format.")
" and not test_docs_examples[docs/index.md:553-585]"
" and not test_docs_examples[docs/index.md:620-645]"
" and not test_docs_examples[docs/index.md:654-732]"
- " and not test_docs_examples[docs/index.md:738-772]"))
+ " and not test_docs_examples[docs/index.md:738-772]")
+ "--ignore=tests/test_docs.py")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'relax-requirements
@@ -8625,10 +8626,7 @@ Interfaces} via data models provided in the JSON format.")
;; '/homeless-shelter/
(setenv "HOME" "/tmp"))))))
(propagated-inputs
- (list python-dotenv
- python-pydantic-2
- python-pyaml
- python-tomli))
+ (list python-dotenv python-pydantic-2))
(native-inputs
(list python-hatchling
python-pytest