summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-03 23:24:52 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:35 +0100
commit821576544c55924fed59ea8fd1da3c422351a450 (patch)
treec3614e80921e4ccd9e8e1ea7bccd0f71fcd1e1e7
parent1538164f251306bb467337f6ae4fc4151733be8d (diff)
gnu: Add python-fastapi-cli.
* gnu/packages/python-web.scm (python-fastapi-cli): New variable. Change-Id: Id20edf30e9c4ba59bc010a96f219cafbcb7ea31e
-rw-r--r--gnu/packages/python-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index da4f62a730..00d70e390d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -10001,6 +10001,30 @@ This package, as opposed to @code{python-fastapi-pagination-minimal}, depends on
all available optional dependencies supported by mainline
@code{fastapi-pagination}."))))
+(define-public python-fastapi-cli
+ (package
+ (name "python-fastapi-cli")
+ (version "0.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fastapi_cli" version))
+ (sha256
+ (base32 "0pk0ldmymc25ys4v6mslzd5vsjh9r69hfylh2ljl29pmarcvdcq2"))))
+ (build-system pyproject-build-system)
+ ;; Tests require fastapi, which depends on this package.
+ (arguments (list #:tests? #false))
+ (propagated-inputs (list python-rich-toolkit python-typer python-uvicorn))
+ (native-inputs
+ (list python-inline-snapshot python-pdm-backend python-pytest))
+ (home-page "https://pypi.org/project/fastapi-cli/")
+ (synopsis
+ "Run and manage FastAPI apps from the command line with FastAPI CLI")
+ (description
+ "FastAPI CLI is a command line program fastapi that you can use to serve
+your FastAPI app, manage your FastAPI project, and more.")
+ (license license:expat)))
+
(define-public python-pyactiveresource
(package
(name "python-pyactiveresource")