summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-31 11:12:14 +0800
committer宋文武 <[email protected]>2025-01-01 10:48:33 +0800
commit786ff769acd6ba8664a18bfd6dd2505bcdf483ae (patch)
tree78c6ba0d4e9baf2d7ba1ac0b28f85a7d7de0b62c
parentc61bed46ed59a2065cf6385f62f54b00bf6f1320 (diff)
gnu: thunar-archive-plugin: Update to 0.5.3.
* gnu/packages/xfce.scm (thunar-archive-plugin): Update to 0.5.3. [source]: Switch to git-fetch. [native-inputs]: Add xfce4-dev-tools. [home-page]: Set to docs.xfce.org. Change-Id: Ib7d14f5aad18aa7aa4575652c7d1cf26c008c75a
-rw-r--r--gnu/packages/xfce.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index a6ceb0b56a..fce53a764d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -855,19 +855,21 @@ and import the new pictures from your camera.")
(define-public thunar-archive-plugin
(package
(name "thunar-archive-plugin")
- (version "0.5.2")
+ (version "0.5.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/thunar-plugins/"
- name "/" (version-major+minor version)
- "/" name "-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/thunar-plugins/"
+ name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1qxdsnwjy8z358yd0avi1h2r6y1izfv26dzlp5fsh3pwpivzhyb3"))))
+ (base32 "1aqvfgn2www5m9764ldafcv5wsknhsdy2hibikzxhpbzd51c8j7l"))))
(build-system gnu-build-system)
- (native-inputs (list pkg-config intltool))
+ (native-inputs (list xfce4-dev-tools))
(inputs (list exo thunar gtk+))
- (home-page "https://www.xfce.org/")
+ (home-page "https://docs.xfce.org/xfce/thunar/archive")
(synopsis "Archive plugin for Thunar file manager")
(description "The Thunar Archive Plugin allows you to create and extract
archive files using the file context menus in the Thunar file manager.")