summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-31 11:05:35 +0800
committer宋文武 <[email protected]>2025-01-01 10:48:33 +0800
commitc61bed46ed59a2065cf6385f62f54b00bf6f1320 (patch)
tree97beeb2fe12a215ce006061a790247c3894d7839
parent0554042415068c29cd27b6c6a1d9e3a59d97eb31 (diff)
gnu: thunar-volman: Switch to git source.
* gnu/packages/xfce.scm (thunar-volman)[source]: Switch to git-fetch. [native-inputs]: Add xfce4-dev-tools. [home-page]: Set to docs.xfce.org. Change-Id: I1b8e6d828183457ecce1fe76a1a033fe716c4081
-rw-r--r--gnu/packages/xfce.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 98673eddd3..a6ceb0b56a 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -830,18 +830,19 @@ fast.")
(version "4.20.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/xfce/thunar-volman/"
- (version-major+minor version) "/"
- "thunar-volman-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/xfce/" name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1nmi3q9jfc4p3dznw96m4ryk8h136qp5bvfipy7mnlcvjm9dinmh"))))
+ (base32 "14cs5hscjrgxvmkxr1d5ank76rxwq7ifvm3g844p9jvhykz6r1aw"))))
(build-system gnu-build-system)
(native-inputs
- (list pkg-config intltool))
+ (list xfce4-dev-tools))
(inputs
(list exo libgudev libnotify libxfce4ui))
- (home-page "https://www.xfce.org/")
+ (home-page "https://docs.xfce.org/xfce/thunar-volman/")
(synopsis "Removable media manager for Thunar")
(description
"Thunar-volman is an extension for the Thunar File Manager, which enables