summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <[email protected]>2025-01-27 15:28:40 -0500
committerJohn Kehayias <[email protected]>2025-01-27 15:37:13 -0500
commit6c2bc0ab6b6aeecd1371db3a14741910339dce45 (patch)
tree9f22016393009ec5bcf2e66a2db6a2e934629a19
parentf5175a5ab2fc1a8c8a4183d36ce4b9cfae591caa (diff)
gnu: vkquake: Use compatible SDL2 version (sdl2-2.0).
This fixes a runtime error of "QUAKE ERROR: Your version of SDL library is incompatible with me. You need a library version in the line of 2.0.6". * gnu/packages/games.scm (vkquake)[inputs]: Replace sdl2 with sdl2-2.0. Change-Id: Iab65796a85a8a8247f565323e5cb1e2c9ae8329e Reported-by: meaty on #guix Change-Id: Ifc4d86014a5a9e8e584edbde8057c7929d534303
-rw-r--r--gnu/packages/games.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ae40e5786e..af819ba2f5 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8075,7 +8075,8 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
,@(strip-keyword-arguments '(#:make-flags #:phases)
(package-arguments quakespasm))))
(inputs (modify-inputs (package-inputs quakespasm)
- (prepend vulkan-headers vulkan-loader)))
+ (prepend vulkan-headers vulkan-loader)
+ (replace "sdl2" sdl2-2.0)))
(description "vkquake is a modern engine for id software's Quake 1.
It includes support for 64 bit CPUs, custom music playback, a new sound driver,
some graphical niceities, and numerous bug-fixes and other improvements.")