summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <[email protected]>2025-01-27 15:19:38 -0500
committerJohn Kehayias <[email protected]>2025-01-27 15:21:28 -0500
commitf5175a5ab2fc1a8c8a4183d36ce4b9cfae591caa (patch)
tree1e378d7359fb0119dd19257e7d36fcee19b74b12
parent06f6d6930c794241b57116448b57b8c745271d4a (diff)
gnu: hyprland: Update to 0.47.0.
* gnu/packages/wm.scm (hyprland): Update to 0.47.0. [arguments]<#:configure-flags>: New field. Add flag to disable trying to build hyprpm. Change-Id: I8a8ff5fd9ff9931322296dadc673ab4ea152520b
-rw-r--r--gnu/packages/wm.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 614d74bd1a..a92e60f5b0 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -359,7 +359,7 @@ commands (lock/unlock/before-sleep) and inhibit.")
(define-public hyprland
(package
(name "hyprland")
- (version "0.46.2")
+ (version "0.47.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/hyprwm/Hyprland"
@@ -376,11 +376,12 @@ commands (lock/unlock/before-sleep) and inhibit.")
"subprojects"))))
(sha256
(base32
- "1hdhk7skf94nm4kk3zs2vqyi0qlc32hb7gfhlyzawj5wq05bawnh"))))
+ "1s54vqniahda893fdn1b0ipx44arqd20kv6rdyqvrh1mp5bnj5s5"))))
(build-system cmake-build-system)
(arguments
(list #:cmake cmake-3.30
#:tests? #f ;No tests.
+ #:configure-flags #~'("-DNO_HYPRPM=True")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'fix-path