summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-03 19:32:16 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:34 +0100
commit09a68f8b4f6d1220b5238171d243ff19a1d494d5 (patch)
tree932aeaf9ca7f6048ec2f70c9e9e1e2cb4e0a009e
parentf2088c6916832286419c51698ac8ee65a4744a17 (diff)
gnu: python-imageio: Update to 2.36.1.
* gnu/packages/python-xyz.scm (python-imageio): Update to 2.36.1. [propagated-inputs]: Remove python-setuptools. [native-inputs]: Add python-setuptools. Change-Id: Iae2fd64ed6acdb4781079fa3e1037dc1a56ab977
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0de719aa85..fb1f4b1e4f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11541,14 +11541,14 @@ from FFMPEG, reliably terminating the process when done.")
(define-public python-imageio
(package
(name "python-imageio")
- (version "2.33.1")
+ (version "2.36.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "imageio" version))
(sha256
(base32
- "1kn1gj9vc1mkirs39x3nkw2d56paiagi24kkxksrig9pn502swkq"))))
+ "0qmy8qbnycas6v2a43qw9pxmd23fm3hpq3qb20b9x6kzyhqx5qg4"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -11575,10 +11575,15 @@ from FFMPEG, reliably terminating the process when done.")
(delete-file "tests/test_freeimage.py"))))))
(inputs (list freeimage))
(propagated-inputs
- (list python-imageio-ffmpeg python-numpy python-pillow python-tifffile python-setuptools))
+ (list python-imageio-ffmpeg python-numpy python-pillow python-tifffile))
(native-inputs
- (list python-black python-flake8 python-fsspec python-pytest
- python-pytest-cov python-wheel))
+ (list python-black
+ python-flake8
+ python-fsspec
+ python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-wheel))
(home-page "https://imageio.github.io/")
(synopsis "Library for reading and writing a wide range of image data")
(description