aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <[email protected]>2014-05-16 12:03:07 -0700
committerPaul Eggert <[email protected]>2014-05-16 12:03:07 -0700
commit87374fcc51a31e13dfb105659594b4906990527f (patch)
treeb99f70c7331ec8ed654df6296486e787add5dcb5 /configure.ac
parentc56327b55d2e75fb0246c9a858e46dd5670699d4 (diff)
* configure.ac (EMACS_CHECK_MODULES): Fix typo and simplify.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 2 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 03b85a5ffa..55e5b8c0b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1375,13 +1375,8 @@ dnl actions.
AC_DEFUN([EMACS_CHECK_MODULES],
[PKG_CHECK_MODULES([$1], [$2],
[$1_CFLAGS=`AS_ECHO(["$$1_CFLAGS"]) | sed -e "$edit_cflags"`
- emacs_check_module_ok=:],
- [:])
- if $emacs_check_module_ok; then
- m4_default([$3], [HAVE_$1=yes])
- else
- m4_default([$4], [HAVE_$1=no])
- fi])
+ m4_default([$3], [HAVE_$1=yes])],
+ [m4_default([$4], [HAVE_$1=no])])])
HAVE_SOUND=no
if test "${with_sound}" != "no"; then