aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <[email protected]>2014-05-16 08:49:13 -0700
committerPaul Eggert <[email protected]>2014-05-16 08:49:13 -0700
commitc56327b55d2e75fb0246c9a858e46dd5670699d4 (patch)
tree0025149767d9633d3cfe20c8ff523bd7a0b22b84 /configure.ac
parent1e217552d247b8b64cda5ac93805f039071204fc (diff)
Don't require pkg-config when building from repository.
* INSTALL: Prefer './configure FOO=BAR' to 'FOO=BAR ./configure'. * INSTALL.REPO: pkg-config is no longer required to build from the repository. * autogen.sh: Don't check for pkg-config. (progs): Remove pkg-config. (pkg_config_min, AUTORECONF_ENV, env_space, ACLOCAL_PATH): Remove. All uses removed. * m4/pkg.m4: New file, built by admin/merge-pkg-config. * configure.ac: Remove unnecessary m4_pattern_forbid of ^PKG_ and an AC_ARG_VAR of PKG_CONFIG_PATH. pkg.m4 does that for us. (EMACS_CHECK_MODULES): Remove workaround for old pkg-config bug, as we use pkg.m4 from a newer pkg-config. * admin/merge-pkg-config: New script. * admin/notes/copyright: Update for m4/*.m4, in particular m4/pkg.m4. * etc/NEWS: Prefer './configure FOO=BAR' to 'FOO=BAR ./configure'. * etc/PROBLEMS (Build-time-problems): Remove pkg-config problem that is no longer an issue. * nt/INSTALL: Remove no-longer-needed notes about pkg-config.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 6 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 5e30c49f2d..03b85a5ffa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -296,7 +296,7 @@ otherwise for the first of `gfile' or `inotify' that is usable.])
dnl http://lists.gnu.org/archive/html/emacs-devel/2008-04/msg01844.html
OPTION_DEFAULT_ON([makeinfo],[don't require makeinfo for building manuals])
-## This might be a 'configure' arg, e.g., autogen.sh might set it.
+## This might be a 'configure' arg.
AC_SUBST([ACLOCAL_PATH])
## Makefile.in needs the cache file name.
@@ -1359,10 +1359,6 @@ AC_SUBST(LIB_MATH)
AC_DEFINE_UNQUOTED(SYSTEM_TYPE, "$SYSTEM_TYPE",
[The type of system you are compiling for; sets `system-type'.])
-m4_pattern_forbid([^PKG_])
-
-AC_ARG_VAR(PKG_CONFIG_PATH, [Colon-separated list of directories
-searched by pkg-config])
pre_PKG_CONFIG_CFLAGS=$CFLAGS
pre_PKG_CONFIG_LIBS=$LIBS
@@ -1372,24 +1368,15 @@ PKG_PROG_PKG_CONFIG(0.9.0)
dnl EMACS_CHECK_MODULES(GSTUFF, gtk+-2.0 >= 1.3 glib = 1.3.4)
dnl acts like PKG_CHECK_MODULES(GSTUFF, gtk+-2.0 >= 1.3 glib = 1.3.4,
dnl HAVE_GSTUFF=yes, HAVE_GSTUFF=no) -- see pkg-config man page --
-dnl except that it works around older pkg-config bugs and
-dnl it postprocesses CFLAGS as needed for --enable-gcc-warnings.
+dnl except that it postprocesses CFLAGS as needed for --enable-gcc-warnings.
dnl EMACS_CHECK_MODULES accepts optional 3rd and 4th arguments that
dnl can take the place of the default HAVE_GSTUFF=yes and HAVE_GSTUFF=no
dnl actions.
AC_DEFUN([EMACS_CHECK_MODULES],
- [dnl pkg-config before 0.26 doesn't check exit status properly; see:
- dnl https://bugs.freedesktop.org/show_bug.cgi?id=29801
- dnl Work around the bug by checking the status ourselves.
- emacs_check_module_ok=false
- AS_IF([test -n "$PKG_CONFIG" &&
- { $PKG_CONFIG --atleast-pkgconfig-version 0.26 ||
- { $PKG_CONFIG --cflags "$2" && $PKG_CONFIG --libs "$2"; }
- } >/dev/null 2>&AS_MESSAGE_LOG_FD],
- [PKG_CHECK_MODULES([$1], [$2],
- [$1_CFLAGS=`AS_ECHO(["$$1_CFLAGS"]) | sed -e "$edit_cflags"`
- emacs_check_module_ok=:],
- [:])])
+ [PKG_CHECK_MODULES([$1], [$2],
+ [$1_CFLAGS=`AS_ECHO(["$$1_CFLAGS"]) | sed -e "$edit_cflags"`
+ emacs_check_module_ok=:],
+ [:])
if $emacs_check_module_ok; then
m4_default([$3], [HAVE_$1=yes])
else