summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 295c2421ec..f50d4c81b2 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2022 Dominic Martinez <[email protected]>
;;; Copyright © 2024 Alexey Abramov <[email protected]>
;;; Copyright © 2024 James Smith <[email protected]>
+;;; Copyright © 2025 Sughosha <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4672,6 +4673,29 @@ network.")
QUIC protocol.")
(license license:expat)))
+(define-public yaz
+ (package
+ (name "yaz")
+ (version "5.34.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.indexdata.com/pub/yaz/yaz-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1h54vda4rgisih309jbdzs6d5vk5mfv5ca9csdbwwrg8hgjbjk6f"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.indexdata.com/resources/software/yaz/")
+ (synopsis "Z39.50 toolkit for C")
+ (description
+ "YAZ is a C/C++ library for information retrieval applications using
+@uref{https://www.loc.gov/z3950/, Z39.50},
+@uref{https://www.loc.gov/standards/sru/, SRU} or
+@uref{https://solr.apache.org/, Solr Web Service} protocols for information
+retrieval. It also offers @uref{https://zoom.z3950.org/, ZOOM} API
+implementing them.")
+ (license license:bsd-3)))
+
(define-public yggdrasil
(package
(name "yggdrasil")