summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm29
-rw-r--r--gnu/packages/golang.scm29
2 files changed, 29 insertions, 29 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index dcd0c4781e..2f97a0085f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -343,6 +343,35 @@ annotations on struct fields. It came as a spin-off from
commands.")
(license license:expat)))
+(define-public go-git-sr-ht-rockorager-tcell-term
+ (package
+ (name "go-git-sr-ht-rockorager-tcell-term")
+ (version "0.10.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~rockorager/tcell-term")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z64yzr2l5j5r5rqi89jk4madn3ak8hw95lva5ra7gnlyhh2vs05"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "git.sr.ht/~rockorager/tcell-term"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-creack-pty
+ go-github-com-gdamore-tcell-v2
+ go-github-com-mattn-go-runewidth))
+ (home-page "https://git.sr.ht/~rockorager/tcell-term")
+ (synopsis "Terminal widget for @code{tcell}")
+ (description
+ "This package provides a virtual terminal widget for the @code{tcell}
+Go library.")
+ (license license:expat)))
+
(define-public go-git-sr-ht-rockorager-vaxis
(package
(name "go-git-sr-ht-rockorager-vaxis")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e9d968eb8e..90ce745340 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3060,35 +3060,6 @@ encoding in Go.")
over strings.")
(license license:expat)))
-(define-public go-git-sr-ht-rockorager-tcell-term
- (package
- (name "go-git-sr-ht-rockorager-tcell-term")
- (version "0.10.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~rockorager/tcell-term")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1z64yzr2l5j5r5rqi89jk4madn3ak8hw95lva5ra7gnlyhh2vs05"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "git.sr.ht/~rockorager/tcell-term"))
- (native-inputs
- (list go-github-com-stretchr-testify))
- (propagated-inputs
- (list go-github-com-creack-pty
- go-github-com-gdamore-tcell-v2
- go-github-com-mattn-go-runewidth))
- (home-page "https://git.sr.ht/~rockorager/tcell-term")
- (synopsis "Terminal widget for @code{tcell}")
- (description
- "This package provides a virtual terminal widget for the @code{tcell}
-Go library.")
- (license license:expat)))
-
(define-public go-github-com-xo-terminfo
(package
(name "go-github-com-xo-terminfo")