summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 06b3848e0a..18c4931c49 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7974,7 +7974,11 @@ files.")
#~(modify-phases %standard-phases
(add-before 'check 'extend-test-timeout
(lambda _
- (setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "10"))))))
+ ;; Some architectures need an even longer timeout. Make it
+ ;; long enough that it should never fail due to timeout.
+ #$@(if (target-riscv64?)
+ #~((setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "100"))
+ #~((setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "10"))))))))
(native-inputs
(list python-setuptools
python-wheel))