summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 7723390c16..8ac10725cd 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015, 2016, 2018, 2019, 2020, 2021 Efraim Flashner <[email protected]>
;;; Copyright © 2016, 2019 Leo Famulari <[email protected]>
;;; Copyright © 2016, 2021 Nicolas Goaziou <[email protected]>
-;;; Copyright © 2016 Christopher Allan Webber <[email protected]>
+;;; Copyright © 2016 Christine Lemmer-Webber <[email protected]>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2017 Stefan Reichör <[email protected]>
;;; Copyright © 2017 Ricardo Wurmus <[email protected]>
@@ -16,6 +16,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <[email protected]>
;;; Copyright © 2020 Oleg Pykhalov <[email protected]>
;;; Copyright © 2020, 2021 Maxim Cournoyer <[email protected]>
+;;; Copyright © 2021 Brice Waegeneire <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -126,16 +127,15 @@ file names.
(define-public libssh
(package
(name "libssh")
- (version "0.9.5")
+ (version "0.9.6")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.libssh.org/projects/libssh.git")
- (commit (string-append "libssh-" version))))
+ (method url-fetch)
+ (uri (string-append "https://www.libssh.org/files/"
+ (version-major+minor version)
+ "/libssh-" version ".tar.xz"))
(sha256
(base32
- "1b2klflmn0mdkcyjl4dqfg116bf9nhmqm4qla5cqa9xis89a5bn6"))
- (file-name (git-file-name name version))))
+ "16w2mc7pyv9mijjlgacbz8dgczc7ig2m6m70w1pld04vpn2zig46"))))
(build-system cmake-build-system)
(outputs '("out" "debug"))
(arguments
@@ -186,7 +186,7 @@ a server that supports the SSH-2 protocol.")
(define-public openssh
(package
(name "openssh")
- (version "8.6p1")
+ (version "8.7p1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://openbsd/OpenSSH/portable/"
@@ -194,7 +194,7 @@ a server that supports the SSH-2 protocol.")
(patches (search-patches "openssh-hurd.patch"))
(sha256
(base32
- "1bnpivgk98h2f9afpp88jv6g9ps83vnpxd031n2jqxi12vdf9rn3"))))
+ "090yxpi03pxxzb4ppx8g8hdpw7c4nf8p0avr6c7ybsaana5lp8vw"))))
(build-system gnu-build-system)
(native-inputs `(("groff" ,groff)
("pkg-config" ,pkg-config)))