summaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 7c7b7e7350..8d2a024378 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015, 2017 Sou Bunnbu <[email protected]>
;;; Copyright © 2015 Alex Kost <[email protected]>
;;; Copyright © 2016, 2017 Efraim Flashner <[email protected]>
-;;; Copyright © 2017, 2018 Rutger Helling <[email protected]>
+;;; Copyright © 2017, 2018, 2019 Rutger Helling <[email protected]>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2018 Ricardo Wurmus <[email protected]>
;;; Copyright © 2019 Kei Kebreau <[email protected]>
@@ -117,7 +117,8 @@ joystick, and graphics hardware.")
(arguments
(substitute-keyword-arguments (package-arguments sdl)
((#:configure-flags flags)
- `(append '("--disable-wayland-shared")
+ `(append '("--disable-wayland-shared" "--enable-video-kmsdrm"
+ "--disable-kmsdrm-shared")
,flags))))
(inputs
;; SDL2 needs to be built with ibus support otherwise some systems