summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index f0e921375b..d5481ced23 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -743,6 +743,12 @@ safety and thread safety guarantees.")
;; for a precompiled library.
(patches (search-patches "rust-1.70-fix-rustix-build.patch")))))))
+(define (make-ignore-test-list strs)
+ "Function to make creating a list to ignore tests a bit easier."
+ (map (lambda (str)
+ `((,str) (string-append "#[ignore]\n" ,str)))
+ strs))
+
;;; Note: Only the latest version of Rust is supported and tested. The
;;; intermediate rusts are built for bootstrapping purposes and should not
;;; be relied upon. This is to ease maintenance and reduce the time