summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0a0428df43..e2b64f984c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28106,6 +28106,7 @@ parentdir_prefix = dask-
(propagated-inputs
(list python-click ;needed at runtime
python-cloudpickle
+ python-dask-expr
python-fsspec
python-importlib-metadata ;needed at runtime for dask/_compatibility.py
python-numpy
@@ -28132,6 +28133,17 @@ larger-than-memory or distributed environments. These parallel collections
run on top of the dynamic task schedulers.")
(license license:bsd-3)))
+(define-public python-dask/bootstrap
+ (package
+ (inherit python-dask)
+ (properties '((hidden? . #true)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments python-dask)
+ ((#:tests? _ #t) #f)))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs python-dask)
+ (delete "python-dask-expr")))))
+
(define-public python-dask-image
(package
(name "python-dask-image")