summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e63ee24b79..3b1db2bdf7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17635,9 +17635,29 @@ libmagic.")))
(sha256
(base32
"0a40574f0rx23gissxmrpjq9cimhjxqsq9wbv5l7620h3blb5510"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
+ #:test-flags
+ #~(list "-n" "0" ; fails: (number->string (parallel-job-count))
+ "-k"
+ (string-append
+ ;; The two "break_01" tests have been failing on
+ ;; Python 3.10:
+ ;; <https://github.com/fabioz/PyDev.Debugger/issues/222>.
+ "not test_set_pydevd_break_01 "
+ ;; This one fails for unknown reasons.
+ "and not test_completion_sockets_and_messages "
+ ;; the GUI event loop requires an X server.
+ "and not test_gui_event_loop_custom "
+ ;; This test validates that 'pydevd' is not in the
+ ;; exception message, but it is due to being part
+ ;; of the build file name present in the message.
+ "and not test_evaluate_exception_trace "
+ ;; These fail on systems with YAMA LSM’s ptrace
+ ;; scope > 0. Upstream issue:
+ ;; https://github.com/fabioz/PyDev.Debugger/issues/218
+ "and not test_attach_to_pid"))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'fix-tests
@@ -17681,30 +17701,10 @@ libmagic.")))
(invoke #+(cxx-for-target) "-shared" "-o" "attach.so"
"-fPIC" "-nostartfiles"
"pydevd_attach_to_process/linux_and_mac/attach.cpp")))
- (replace 'check
+ (add-before 'check 'pre-check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (setenv "PYDEVD_USE_CYTHON" "YES")
- (invoke "pytest" "-vv"
- "-n" "0" ; fails: (number->string (parallel-job-count))
- "-k"
- (string-append
- ;; The two "break_01" tests have been failing on
- ;; Python 3.10:
- ;; <https://github.com/fabioz/PyDev.Debugger/issues/222>.
- "not test_set_pydevd_break_01 "
- ;; This one fails for unknown reasons.
- "and not test_completion_sockets_and_messages "
- ;; the GUI event loop requires an X server.
- "and not test_gui_event_loop_custom "
- ;; This test validates that 'pydevd' is not in the
- ;; exception message, but it is due to being part
- ;; of the build file name present in the message.
- "and not test_evaluate_exception_trace "
- ;; These fail on systems with YAMA LSM’s ptrace
- ;; scope > 0. Upstream issue:
- ;; https://github.com/fabioz/PyDev.Debugger/issues/218
- "and not test_attach_to_pid")))))
+ (setenv "PYDEVD_USE_CYTHON" "YES"))))
(add-after 'install 'install-attach-binary
(lambda _
(install-file "attach.so"