summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm76
1 files changed, 40 insertions, 36 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1bdc7dafa5..3faa6db06a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -49,7 +49,7 @@
;;; Copyright © 2021 Alice Brenon <[email protected]>
;;; Copyright © 2022 John Kehayias <[email protected]>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <[email protected]>
-;;; Copyright © 2022, 2023 Felix Gruber <[email protected]>
+;;; Copyright © 2022, 2023, 2025 Felix Gruber <[email protected]>
;;; Copyright © 2022 Peter Polidoro <[email protected]>
;;; Copyright © 2022 Antero Mejr <[email protected]>
;;; Copyright © 2022 Luis Henrique Gomes Higino <[email protected]>
@@ -7696,44 +7696,48 @@ them to a designated prefix.")
(define-public python-warcio
;; The PyPI release is missing some test support files (see:
;; https://github.com/webrecorder/warcio/issues/132).
- (let ((revision "0")
- (commit "aa702cb321621b233c6e5d2a4780151282a778be"))
- (package
- (name "python-warcio")
- (version (git-version "1.7.4" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/webrecorder/warcio")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "11afr6zy3r6rda81010iq496dazg4xid0izg3smg6ighpmvsnzf2"))))
- (build-system pyproject-build-system)
- (arguments
- (list
- #:test-flags ; These tests fail due to networking requirements.
- '(list "-k" (format #f "not ~a"
- (string-join
- '("test_post_chunked"
- "test_remote"
- "test_capture_http_proxy"
- "test_capture_https_proxy"
- "test_capture_https_proxy_same_session")
- " and not ")))))
- (native-inputs
- ;; These inputs are required for the test suite.
- (list python-httpbin python-pytest-cov python-requests
- python-wsgiprox))
- (home-page "https://github.com/webrecorder/warcio")
- (synopsis "Streaming web archival archive (WARC) library")
- (description "warcio is a Python library to read and write the WARC format
+ (package
+ (name "python-warcio")
+ (version "1.7.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/webrecorder/warcio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0r3kijsm8wsbipi5pxsrqpg5nn4w8iaw5i8010b0ligmfxnxamlb"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags ; These tests fail due to networking requirements.
+ '(list "-k" (format #f "not ~a"
+ (string-join
+ '("test_post_chunked"
+ "test_remote"
+ "test_capture_http_proxy"
+ "test_capture_https_proxy"
+ "test_capture_https_proxy_same_session")
+ " and not "))
+ ; The following test requires the hookdns package.
+ "--ignore=test/test_capture_http_proxy.py")))
+ (native-inputs
+ ;; These inputs are required for the test suite.
+ (list python-httpbin
+ python-pytest-cov
+ python-requests
+ python-setuptools
+ python-wheel
+ python-wsgiprox))
+ (home-page "https://github.com/webrecorder/warcio")
+ (synopsis "Streaming web archival archive (WARC) library")
+ (description "warcio is a Python library to read and write the WARC format
commonly used in Web archives. It is designed for fast, low-level access to
web archival content, oriented around a stream of WARC records rather than
files.")
- (license license:asl2.0))))
+ (license license:asl2.0)))
(define-public python-websockets
(package