summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cc6509ea1d..6f6b1dadfe 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2021, 2022, 2024 Arun Isaac <[email protected]>
;;; Copyright © 2021, 2022, 2024 jgart <[email protected]>
;;; Copyright © 2021 Alice Brenon <[email protected]>
+;;; Copyright © 2021 Mekeor Melire <[email protected]>
;;; Copyright © 2022 John Kehayias <[email protected]>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <[email protected]>
;;; Copyright © 2022, 2023, 2025 Felix Gruber <[email protected]>
@@ -1464,6 +1465,34 @@ Model} (SAM) templates into AWS CloudFormation templates.")
emit information from within their applications to the AWS X-Ray service.")
(license license:asl2.0)))
+(define-public python-publicsuffixlist
+ (package
+ (name "python-publicsuffixlist")
+ (version "1.0.2.20250202")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "publicsuffixlist" version))
+ (sha256
+ (base32 "0llam7g7sv08lcfgy18iph8br8ldjmy2qbjaykc9pd3z4iisb0yd"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (home-page "https://github.com/ko-zu/psl")
+ (synopsis "Public suffix list for Python")
+ (description
+ "This package provides an implementation of
+@url{https://publicsuffix.org/, Public Suffix List } as Python library.
+
+Features:
+@itemize
+@item supports IDN (unicode and punycoded)
+@item shipped with built-in PSL and an updater script
+@item written in Pure Python with no library dependencies
+@end itemize")
+ (license license:mpl2.0)))
+
(define-public python-python3-saml
(package
(name "python-python3-saml")