summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 93d3b25272..862e101f6a 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2022-2024 Efraim Flashner <[email protected]>
;;; Copyright © 2016-2020, 2022 Marius Bakke <[email protected]>
;;; Copyright © 2019 Tobias Geerinckx-Rice <[email protected]>
-;;; Copyright © 2019, 2021, 2022, 2023 Maxim Cournoyer <[email protected]>
+;;; Copyright © 2019, 2021, 2022, 2023, 2024 Maxim Cournoyer <[email protected]>
;;; Copyright © 2019 Giacomo Leidi <[email protected]>
;;; Copyright © 2020 Pierre Langlois <[email protected]>
;;; Copyright © 2020, 2021, 2022, 2023, 2024 Vinicius Monego <[email protected]>
@@ -2287,6 +2287,26 @@ Python, from the Sheffield machine learning group. GPy implements a range of
machine learning algorithms based on GPs.")
(license license:bsd-3)))
+(define-public python-pods
+ (package
+ (name "python-pods")
+ (version "0.1.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pods" version))
+ (sha256
+ (base32 "157xxs12qbnz1g6agy0a4dqhsa4msbqryrxpg5w3r3pb8gxdl4dh"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f)) ;no test suite
+ (propagated-inputs (list python-pandas python-pyyaml python-scipy
+ python-tables))
+ (home-page "https://github.com/lawrennd/ods")
+ (synopsis "Python software for Open Data Science")
+ (description "This package provides utilities and tools for open data
+science including tools for accessing data sets in Python.")
+ (license license:bsd-3)))
+
(define-public python-pyfma
(package
(name "python-pyfma")