summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index af2e1fa355..9a401160be 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -925,33 +925,6 @@ files and/or directories.")
advanced doctest support and enables the testing of reStructuredText files.")
(license license:bsd-3)))
-(define-public python-pytest-exploratory
- (package
- (name "python-pytest-exploratory")
- (version "0.5")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest_exploratory" version))
- (sha256
- (base32 "159rcqv6wrdqdlag1gz39n6fk58232hbxshan043ljgpp1qfs6xk"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "tests")))))))
- (propagated-inputs
- (list python-ipython python-py python-pytest))
- (native-inputs (list python-pytest))
- (home-page "https://github.com/nokia/pytest-exploratory")
- (synopsis "Interactive console for Pytest")
- (description "This Pytest plugin provides an IPython extension that allows
-for interactively selecting and running Pytest tests.")
- (license license:expat)))
-
(define-public python-pytest-filter-subpackage
(package
(name "python-pytest-filter-subpackage")