summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-11 13:43:32 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:43 +0100
commit45dd5a53bd2c369ba64a1a63688bd0e5c8853f43 (patch)
tree25173dbb62d1964303085b3253d05695c5a174fb /gnu/packages/python-check.scm
parent1299d57b04f1c96544e4ea88512b102b775de8b7 (diff)
gnu: Remove python-pytest-exploratory.
This package fails its own test suite, even in the latest version. It has no other users. * gnu/packages/python-check.scm (python-pytest-exploratory): Remove variable. Change-Id: I95040b02a7b6cfc05dbd7def9dc5a7d0a3a315f7
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index af2e1fa355..9a401160be 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -925,33 +925,6 @@ files and/or directories.")
advanced doctest support and enables the testing of reStructuredText files.")
(license license:bsd-3)))
-(define-public python-pytest-exploratory
- (package
- (name "python-pytest-exploratory")
- (version "0.5")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest_exploratory" version))
- (sha256
- (base32 "159rcqv6wrdqdlag1gz39n6fk58232hbxshan043ljgpp1qfs6xk"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "tests")))))))
- (propagated-inputs
- (list python-ipython python-py python-pytest))
- (native-inputs (list python-pytest))
- (home-page "https://github.com/nokia/pytest-exploratory")
- (synopsis "Interactive console for Pytest")
- (description "This Pytest plugin provides an IPython extension that allows
-for interactively selecting and running Pytest tests.")
- (license license:expat)))
-
(define-public python-pytest-filter-subpackage
(package
(name "python-pytest-filter-subpackage")