summaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index daf7b933ad..6c3a47986d 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -25,6 +25,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages protobuf)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -49,16 +50,18 @@
(define-public fstrm
(package
(name "fstrm")
- (version "0.3.2")
+ (version "0.6.1")
(source
(origin
(method url-fetch)
- (uri (string-append "https://dl.farsightsecurity.com/dist/" name "/"
- name "-" version ".tar.gz"))
+ (uri (string-append "https://dl.farsightsecurity.com/dist/fstrm/"
+ "fstrm-" version ".tar.gz"))
(sha256
- (base32
- "1i9y8a1712aj80p5a1kcp378bnjrg3s2127q7304hklhmjcrjl1d"))))
+ (base32 "13q9iz5fpp607zvk0i39158fvvjciz4y5k14rly94b9ak0gar95w"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "--disable-static")))
(native-inputs
(list pkg-config))
(inputs
@@ -79,8 +82,8 @@ XML, JSON, MessagePack, YAML, etc.
Frame Streams can be used either as a streaming transport over a reliable byte
stream socket (TCP sockets, TLS connections, @code{AF_UNIX} sockets, etc.) for
data in motion, or as a file format for data at rest.")
- (license (list license:asl2.0
- (license:non-copyleft #f "See libmy/argv*")))))
+ (license (list license:expat ; the combined work
+ license:hpnd)))) ; libmy/argv*
(define-public protobuf
(package