summaryrefslogtreecommitdiff
path: root/gnu/packages/nettle.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/nettle.scm')
-rw-r--r--gnu/packages/nettle.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/nettle.scm b/gnu/packages/nettle.scm
index 753e2d6e7e..7f85f54fbf 100644
--- a/gnu/packages/nettle.scm
+++ b/gnu/packages/nettle.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <[email protected]>
-;;; Copyright © 2016 Mark H Weaver <[email protected]>
+;;; Copyright © 2016, 2021 Mark H Weaver <[email protected]>
;;; Copyright © 2017 Efraim Flashner <[email protected]>
;;; Copyright © 2021 Maxim Cournoyer <[email protected]>
;;;
@@ -25,6 +25,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages m4))
@@ -77,6 +78,7 @@ themselves.")
;; cannot use it yet. So keep it separate.
(package (inherit nettle-2)
(version "3.5.1")
+ (replacement nettle-3.5/fixed)
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/nettle/nettle-"
@@ -91,16 +93,23 @@ themselves.")
;; at run time based on CPU features (starting from 3.1.)
`(cons "--enable-fat" ,flags))))))
+(define nettle-3.5/fixed
+ (package-with-extra-patches
+ nettle-3.5
+ (search-patches "nettle-3.5-check-_pkcs1_sec_decrypt-msg-len.patch"
+ "nettle-3.5-CVE-2021-3580-pt1.patch"
+ "nettle-3.5-CVE-2021-3580-pt2.patch")))
+
(define-public nettle-3.7
(package (inherit nettle-3.5)
- (version "3.7.2")
+ (version "3.7.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/nettle/nettle-"
version ".tar.gz"))
(sha256
(base32
- "0qpi1qp3bcvqdsaxy2pzg530db95x8qjahkynxgwvr6dy5760ald"))))))
+ "1w5wwc3q0r97d2ifhx77cw7y8s20bm8x52is9j93p2h47yq5w7v6"))))))
;;; Upgrading Nettle on master would cause 10000+ packages to be rebuilt.
(define-public nettle nettle-3.5)