summaryrefslogtreecommitdiff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index 311e244608..e29f3b4569 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013 Andreas Enge <[email protected]>
;;; Copyright © 2017 Efraim Flashner <[email protected]>
;;; Copyright © 2018 Tobias Geerinckx-Rice <[email protected]>
-;;; Copyright © 2018 Ludovic Courtès <[email protected]>
+;;; Copyright © 2018, 2019 Ludovic Courtès <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -69,6 +69,13 @@
(lambda _
(setenv "LSOF_CC" "gcc")
(setenv "LSOF_MAKE" "make")
+
+ ;; By default, the makefile captures the output of 'uname -a'.
+ ;; Provide a fixed output instead to make builds reproducible.
+ (setenv "LSOF_SYSINFO"
+ (string-append "GNU/" (utsname:sysname (uname))
+ " (GNU Guix)"))
+
(invoke "./Configure" "linux")
#t))
(add-after 'configure 'patch-timestamps