summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4120355b84..1a3ccb610c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -42,7 +42,7 @@
;;; Copyright © 2020 Pierre Neidhardt <[email protected]>
;;; Copyright © 2020 Chris Marusich <[email protected]>
;;; Copyright © 2020 Vincent Legoll <[email protected]>
-;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <[email protected]>
+;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <[email protected]>
;;; Copyright © 2020 Morgan Smith <[email protected]>
;;; Copyright © 2020 John Soo <[email protected]>
;;; Copyright © 2020, 2022 Michael Rohleder <[email protected]>
@@ -2390,7 +2390,14 @@ parameters.")
(let* ((out #$output)
(dup (append-map (cut find-files out <>)
'("^kill" "^uptime"))))
- (for-each delete-file dup)))))))
+ (for-each delete-file dup))))
+ #$@(if (system-hurd?)
+ #~((add-after 'unpack 'skip-tests
+ (lambda _
+ (substitute* "library/tests/test_version.c"
+ (("^int main\\(.*" all)
+ (string-append all "{\n exit (77);//"))))))
+ #~()))))
(inputs (list ncurses))
(native-inputs (list pkg-config))
(home-page "https://gitlab.com/procps-ng/procps/")