summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index b617b95eb8..63d7dd99c3 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1090,17 +1090,16 @@ basic needs and easy to configure for those who want special setups.")
(define-public libksysguard
(package
(name "libksysguard")
- (version "5.27.7")
+ (version "6.1.2")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/plasma/" version
"/libksysguard-" version ".tar.xz"))
- (patches (search-patches "libksysguard-qdiriterator-follow-symlinks.patch"))
(sha256
- (base32 "066bjar4105bfyry6ni7nnikz66bqzy5nvssz6vm4np3aa996ak8"))))
+ (base32 "1l1fy5i9yxh7fnxfyfsk0hnyd1vfzac336kcfwklkqa7l796hpc0"))))
(native-inputs
- (list bash-minimal extra-cmake-modules pkg-config qttools-5))
+ (list bash-minimal extra-cmake-modules pkg-config qttools))
(inputs
(list kauth
kcompletion
@@ -1120,22 +1119,21 @@ basic needs and easy to configure for those who want special setups.")
libcap
libpcap
`(,lm-sensors "lib")
- plasma-framework
- qtbase-5
- qtdeclarative-5
- qtscript
- qtwebchannel-5
- qtwebengine-5
- qtx11extras
+ libplasma
+ qtdeclarative
+ qtwebchannel
+ qtwebengine
zlib))
(build-system qt-build-system)
(arguments
- (list #:phases #~(modify-phases %standard-phases
- (add-after 'unpack 'fix-test
- (lambda* _
- (substitute* "autotests/processtest.cpp"
- (("/bin/sh")
- (which "bash"))))))))
+ (list
+ #:qtbase qtbase
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-test
+ (lambda* _
+ (substitute* "autotests/processtest.cpp"
+ (("/bin/sh")
+ (which "bash"))))))))
(home-page "https://userbase.kde.org/KSysGuard")
(synopsis "Network enabled task and system monitoring")
(description "KSysGuard can obtain information on system load and