summaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm130
1 files changed, 128 insertions, 2 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index d5941b6c0f..ff21c9c724 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2020 Brice Waegeneire <[email protected]>
;;; Copyright © 2021 Evgeny Pisemsky <[email protected]>
;;; Copyright © 2021 Léo Le Bouter <[email protected]>
+;;; Copyright © 2021 Denis Carikli <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,19 +39,26 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages openldap)
+ #:use-module (gnu packages pciutils)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages polkit)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-web)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix svn-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils))
@@ -100,6 +108,36 @@ calibrated, and restored when the calibration is applied.")
(license (list license:bsd-3 ; FindDDCUtil.cmake
license:gpl2+)))) ; everything else
+(define-public ddcui
+ (package
+ (name "ddcui")
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rockowitz/ddcui")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0myma1zw6dlygv3xbin662d91zcnwss10syf12q2fppkrd8qdgqf"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; No test suite
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("ddcutil" ,ddcutil)
+ ("glib" ,glib)
+ ("qtbase" ,qtbase-5)))
+ (home-page "https://www.ddcutil.com/")
+ (synopsis "Graphical user interface for ddcutil")
+ (description "ddcui is a graphical user interface for ddcutil, implemented
+using Qt. It provide a dynamic way to inspect and configure external monitors
+through the Display Data Channel Command Interface (@dfn{DDC/CI}) protocol.")
+ (license (list license:gpl2+))))
+
(define-public edid-decode
(let ((commit "74b64180d67bb009d8d9ea1b6f18ad41aaa16396") ; 2020-04-22
(revision "1"))
@@ -137,6 +175,94 @@ calibrated, and restored when the calibration is applied.")
human-readable format and checks if it conforms to the standards.")
(license license:expat))))
+(define-public h-client
+ (let ((version "0.0a0")
+ (revision 138))
+ (package
+ (name "h-client")
+ (version (string-append version "-" (number->string revision)))
+ (source
+ (origin
+ (method svn-fetch)
+ (uri
+ (svn-reference
+ (url "https://svn.savannah.nongnu.org/svn/h-client/trunk/h-client")
+ (revision revision)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pdd2qhyaa5vh7z4rkpwjlby1flkwhzmp8zlglalx5y5sv95l4kp"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ ;; Tests depends on /etc/os-release which does not exist in the
+ ;; build container.
+ #:tests? #f))
+ (inputs
+ `(("python2" ,python-2)
+ ("python2-pycurl", python2-pycurl)
+ ("python2-pygtk", python2-pygtk)
+ ("pciutils", pciutils)
+ ("usbutils", usbutils)))
+ (synopsis "Graphical client for the h-node hardware database
+project")
+ (description
+ "The h-node project (https://www.h-node.org) aims to build a database of
+hardware that works with fully free operating systems.
+h-client is a GTK+ graphical client that is able to retrieves information on
+the hardware inside the computer it's running on, and on peripherals connected
+to it, and help you submit that information to the h-node project along with
+whether the hardware works with a fully free operating system or not.")
+ (home-page "https://savannah.nongnu.org/projects/h-client/")
+ (license license:gpl3+))))
+
+(define-public i7z
+ (let ((revision "0")
+ (commit "1a41ff13db747e962456ddbb5ccb2b7fc43ca0cb"))
+ (package
+ (name "i7z")
+ (version (git-version "0.28" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/afontenot/i7z")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jxm63a8y1mfl1sa4mzzfs3bgnym6achj1yc0jglmp05xal16lm1"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (for-each delete-file-recursively
+ (list "src/GUI"
+ "src/perfmon-i7z"
+ "scripts"))))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "prefix=" (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target)))
+ #:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (home-page "https://github.com/afontenot/i7z")
+ (synopsis "Thermal and C-state reporting on older Intel Core CPUs")
+ (description
+ "The @command{i7z} utility accurately measures the current frequency
+and temperature of older Intel Core (i3, i5, and i7) processors including the
+Nehalem, Sandy Bridge, and Ivy Bridge generations. Reliable support for newer
+CPUs is not guaranteed, as this package has not seen significant development
+since 2013.
+
+If your processor is supported, you'll get detailed reports on Turbo Boost and
+clock multipliers, core voltage, and time spent in different C-states. This
+information can be viewed in real time and/or logged to a file.")
+ (supported-systems (list "x86_64-linux"))
+ (license license:gpl2))))
+
(define-public libsmbios
(package
(name "libsmbios")
@@ -240,7 +366,7 @@ Memtest86+ cannot currently be used on computers booted with UEFI.")
(define-public memtester
(package
(name "memtester")
- (version "4.5.0")
+ (version "4.5.1")
(source
(origin
(method url-fetch)
@@ -248,7 +374,7 @@ Memtest86+ cannot currently be used on computers booted with UEFI.")
(uri (string-append "http://pyropus.ca/software/memtester/old-versions/"
"memtester-" version ".tar.gz"))
(sha256
- (base32 "0dxfwayns3hjjplkxkpkm1409lmjlpi4chcrahcvdbnl0q6jpmcf"))))
+ (base32 "0issrasdihav8jgsqb49cfyj0v564z8k9lyg2jrq9h3n4lwc4pqw"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags