summaryrefslogtreecommitdiff
path: root/gnu/packages/gpodder.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gpodder.scm')
-rw-r--r--gnu/packages/gpodder.scm62
1 files changed, 54 insertions, 8 deletions
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index c4dc50c2f9..07df1da2f2 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019, 2020, 2021 Pierre Langlois <[email protected]>
-;;; Copyright © 2020 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2021 Stefan Reichör <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,25 +22,34 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages groff)
+ #:use-module (gnu packages mp3)
+ #:use-module (gnu packages music)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
- #:use-module (gnu packages video))
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages xml))
(define-public gpodder
(package
(name "gpodder")
- (version "3.10.18")
+ (version "3.10.21")
(source
(origin
(method git-fetch)
@@ -47,7 +57,7 @@
(url "https://github.com/gpodder/gpodder")
(commit version)))
(sha256
- (base32 "1d73q46sqandzbn74nfw9bzzah99z91wsxq2hcivwdgnsv2g2d8y"))
+ (base32 "0n73jm5ypsj962gpr0dk10lqh83giqsczm63wchyhmrkyf1wgga1"))
(file-name (git-file-name name version))
(patches (search-patches "gpodder-disable-updater.patch"))))
(build-system python-build-system)
@@ -60,12 +70,14 @@
("python-pytest-httpserver" ,python-pytest-httpserver)
("which" ,which)))
(inputs
- `(("gtk+" ,gtk+)
+ `(("bash-minimal" ,bash-minimal)
+ ("gtk+" ,gtk+)
("python-pygobject" ,python-pygobject)
("python-pycairo" ,python-pycairo)
("python-requests" ,python-requests)
("python-dbus" ,python-dbus)
("python-html5lib" ,python-html5lib)
+ ("python-mutagen" ,python-mutagen)
("python-mygpoclient" ,python-mygpoclient)
("python-podcastparser" ,python-podcastparser)
("youtube-dl" ,youtube-dl)
@@ -81,11 +93,12 @@
(("xdg-open") (string-append xdg-utils "/bin/xdg-open")))
#t)))
(replace 'check
- (lambda _
+ (lambda* (#:key tests? #:allow-other-keys)
; The `unittest' target overrides the PYTHONPATH variable.
(substitute* "makefile"
(("PYTHONPATH=src/") "PYTHONPATH=${PYTHONPATH}:src/"))
- (invoke "make" "unittest")))
+ (when tests?
+ (invoke "make" "unittest"))))
;; 'msgmerge' introduces non-determinism by resetting the
;; POT-Creation-Date in .po files.
(add-before 'install 'do-not-run-msgmerge
@@ -136,7 +149,7 @@ locally for later listening.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("qt" ,qtbase)))
+ `(("qt" ,qtbase-5)))
(arguments
`(#:configure-flags '("-DMYGPO_BUILD_TESTS=ON")
;; TODO: Enable tests when https://github.com/gpodder/gpodder/issues/446
@@ -203,3 +216,36 @@ downloading episode status changes.")
provide an easy and reliable way of parsing RSS and Atom-based podcast feeds
in Python.")
(license license:isc)))
+
+(define-public castget
+ (package
+ (name "castget")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mlj/castget")
+ (commit (string-append "rel_" (string-replace-substring
+ version "." "_")))))
+ (sha256
+ (base32 "1129x64rw587q3sdpa3lrgs0gni5f0siwbvmfz8ya4zkbhgi2ik7"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("ronn-ng" ,ronn-ng)))
+ (inputs `(("curl" ,curl)
+ ("glib" ,glib)
+ ("id3lib" ,id3lib)
+ ("libxml2" ,libxml2)))
+ (synopsis "Command line podcast downloader")
+ (description
+ "castget is a simple, command-line based RSS enclosure downloader. It is
+primarily intended for automatic, unattended downloading of podcasts. It uses
+libcurl for the download process.")
+ (license license:lgpl2.1+)
+ (home-page "https://castget.johndal.com")))