summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b9343512c9..b6919ade83 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4585,35 +4585,6 @@ designed to clean up raw terminal output by stripping escape sequences,
optionally preserving color.")
(license license:expat)))
-;; XXX: This repository has been archived by the owner on Dec 1, 2021. It is
-;; now read-only.
-(define-public go-github-com-pkg-errors
- (package
- (name "go-github-com-pkg-errors")
- (version "0.9.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pkg/errors")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1761pybhc2kqr6v5fm8faj08x9bql8427yqg6vnfv6nhrasx1mwq"))))
- (build-system go-build-system)
- (arguments
- (list
- ;; Tests fail with a newer version of Golang (1.21) due to some API
- ;; changes in how the module path is calculated which is not reflected
- ;; in tests.
- #:tests? #f
- #:import-path "github.com/pkg/errors"))
- (synopsis "Go error handling primitives")
- (description "This package provides @code{error}, which offers simple
-error handling primitives in Go.")
- (home-page "https://github.com/pkg/errors")
- (license license:bsd-2)))
-
(define-public go-github-com-maruel-panicparse
(package
(name "go-github-com-maruel-panicparse")