summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm32
1 files changed, 22 insertions, 10 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1e129c39a5..a578536b43 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2536,33 +2536,45 @@ characters with their ASCII approximations.")
(license license:asl2.0))))
(define-public go-github-com-surgebase-porter2
- (let ((commit "56e4718818e8dc4ea5ba6348402fc7661863732a")
- (revision "1"))
(package
(name "go-github-com-surgebase-porter2")
- (version (git-version "0.0.0" revision commit))
+ (version "0.0.0-20150829210152-56e4718818e8")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/surgebase/porter2")
- (commit commit)))
- (file-name (string-append "go-github-com-surgebase-porter2-"
- version "-checkout"))
+ (url "https://github.com/surgebase/porter2")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
(sha256
(base32
"1ivcf83jlj9s7q5y9dfbpyl0br35cz8fcp0dm8sxxvqh54py06v2"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/surgebase/porter2"))
+ (list
+ #:import-path "github.com/surgebase/porter2"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-build
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* "cmd/suffixfsm/suffixfsm.go"
+ ;; fmt.Println arg list ends with redundant newline
+ (("fmt.Println") "fmt.Printf"))))))))
(native-inputs
- (list go-github-com-stretchr-testify go-github-com-surge-glog))
+ (list go-github-com-agonopol-go-stem
+ go-github-com-dchest-stemmer
+ go-github-com-kljensen-snowball
+ go-github-com-reiver-go-porterstemmer
+ go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-surge-glog))
(home-page "https://github.com/surgebase/porter2")
(synopsis "Go library implementing english Porter2 stemmer")
(description "Porter2 implements the
@url{http://snowball.tartarus.org/algorithms/english/stemmer.html, english
Porter2 stemmer}. It is written completely using finite state machines to do
suffix comparison, rather than the string-based or tree-based approaches.")
- (license license:asl2.0))))
+ (license license:asl2.0)))
(define-public go-github-com-twpayne-go-vfsafero
(package