summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d398dd1e0e..d7fd1f4a3e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -8136,6 +8136,33 @@ ansi.")
customized globally.")
(license license:expat)))
+;; Some packages (Yggdrasil) need it to compile it's a tiny package and it's
+;; easier to bundle it than to patch it out.
+(define-public go-github-com-kardianos-minwinsvc
+ (package
+ (name "go-github-com-kardianos-minwinsvc")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kardianos/minwinsvc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02k2vibmm65bzkdjpmllphvq88wwyz3m02lbz8bffcpxjad2453v"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/kardianos/minwinsvc"))
+ (home-page "https://github.com/kardianos/minwinsvc/")
+ (synopsis "Minimal windows only service stub for Go")
+ (description
+ "Go programs designed to run from most *nix style operating systems can
+import this package to enable running programs as services without modifying
+them.")
+ (license license:zlib)))
+
(define-public go-github-com-kardianos-service
(package
(name "go-github-com-kardianos-service")