summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index fdd4931a2c..b73868c04c 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2022 dan <[email protected]>
;;; Copyright © 2022 Cairn <[email protected]>
;;; Copyright © 2023, 2024 John Kehayias <[email protected]>
+;;; Copyright © 2022-2023, 2025 Adam Faiz <[email protected]>
;;; Copyright © 2024 Nicolas Graves <[email protected]>
;;; Copyright © 2024 Maxim Cournoyer <[email protected]>
;;; Copyright © 2025 Sharlatan Hellseher <[email protected]>
@@ -678,6 +679,25 @@ GUI toolkit, lighting and physics frameworks and @code{Tiled} TMX format
support.")
(license license:lgpl3+)))
+(define-public python-neteria
+ (package
+ (name "python-neteria")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "neteria" version))
+ (sha256
+ (base32 "1azlix80a6vns2i3z0bdbqk32kx8s2gjh2nvshab235fd9h85yv7"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-rsa))
+ (home-page "https://pypi.org/project/neteria/")
+ (synopsis "Simple game networking library")
+ (description
+ "This package provides a game networking framework for Python.")
+ (license license:gpl3+)))
+
(define-public slade
(package
(name "slade")