summaryrefslogtreecommitdiff
path: root/gnu/packages/configuration-management.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/configuration-management.scm')
-rw-r--r--gnu/packages/configuration-management.scm21
1 files changed, 2 insertions, 19 deletions
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index 6d81f0dcac..b654975a42 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -50,6 +50,7 @@
(arguments
(list
#:import-path "github.com/twpayne/chezmoi"
+ #:embed-files #~(list ".*\\.xml")
#:install-source? #f
#:phases
#~(modify-phases %standard-phases
@@ -80,25 +81,7 @@
"secretkeepassxc.txt"
"secretlastpass.txt"
"secretonepassword.txt"
- "secretpass.txt"))))
- ;; TODO: Implement it in go-build-system.
- ;;
- ;; This happens due to Golang can't determine the valid directory of
- ;; the module of embed file which is symlinked during setup
- ;; environment phase, but easy resolved after coping file from the
- ;; store to the build directory of the current package, see details
- ;; in Golang source:
- ;;
- ;; - URL: <https://github.com/golang/go/blob/>
- ;; - commit: 82c14346d89ec0eeca114f9ca0e88516b2cda454
- ;; - file: src/cmd/go/internal/load/pkg.go#L2059
- (add-after 'unpack 'fix-embed-files
- (lambda _
- (for-each (lambda (file)
- (let ((file-store-path (readlink file)))
- (delete-file file)
- (copy-recursively file-store-path file)))
- (find-files "src" (string-append "\\.xml$"))))))))
+ "secretpass.txt")))))))
(native-inputs
(list go-github-com-masterminds-sprig-v3
go-github-com-bmatcuk-doublestar-v2