summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm465
1 files changed, 376 insertions, 89 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c62c5970b8..53c7d048c9 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2202,6 +2202,53 @@ conditions or various species. @code{AMOUNTAIN} aims to search active modules
in multi-layer WGCN using a continuous optimization approach.")
(license license:gpl2+)))
+(define-public r-amplican
+ (package
+ (name "r-amplican")
+ (version "1.20.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "amplican" version))
+ (sha256
+ (base32
+ "1c990i6gxbarcpbdpkz017x94spwzap95l95synlizbkyif4z8ij"))))
+ (properties `((upstream-name . "amplican")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocgenerics
+ r-biocparallel
+ r-biostrings
+ r-clustercrit
+ r-data-table
+ r-dplyr
+ r-genomeinfodb
+ r-genomicranges
+ r-ggplot2
+ r-ggthemes
+ r-gridextra
+ r-gtable
+ r-iranges
+ r-knitr
+ r-matrix
+ r-matrixstats
+ r-rcpp
+ r-rmarkdown
+ r-s4vectors
+ r-shortread
+ r-stringr
+ r-waffle))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/valenlab/amplican")
+ (synopsis "Automated analysis of CRISPR experiments")
+ (description
+ "The package performs alignment of the amplicon reads, normalizes
+gathered data, calculates multiple statistics (e.g. cut rates, frameshifts)
+and presents the results in the form of aggregated reports. Data and
+statistics can be broken down by experiments, barcodes, user defined groups,
+guides and amplicons allowing for quick identification of potential
+problems.")
+ (license license:gpl3)))
+
(define-public r-amaretto
(package
(name "r-amaretto")
@@ -2287,13 +2334,13 @@ analysis, modelling, and visualization of spike-in controls.")
(define-public r-ancombc
(package
(name "r-ancombc")
- (version "2.0.1")
+ (version "2.0.2")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "ANCOMBC" version))
(sha256
(base32
- "1bwzvi6j3s66dcll1lb4xy25j4nfn1ln6mc3flh0wgy13l26x8m6"))))
+ "0dlinv4vhxgni8ygzvfw8pbc6d1v9x5chhrpxblhs2c65bkgyxz5"))))
(properties `((upstream-name . "ANCOMBC")))
(build-system r-build-system)
(propagated-inputs
@@ -2337,6 +2384,65 @@ Methodologies included in the @code{ANCOMBC} package were designed to correct
these biases and construct statistically consistent estimators.")
(license license:artistic2.0)))
+(define-public r-animalcules
+ (package
+ (name "r-animalcules")
+ (version "1.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "animalcules" version))
+ (sha256
+ (base32
+ "1alpsamrglgvzhcibkaf7m3gyiv61wbj1gvsq4lw6vjka100j9qr"))))
+ (properties `((upstream-name . "animalcules")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ape
+ r-assertthat
+ r-biomformat
+ r-caret
+ r-covr
+ r-deseq2
+ r-dplyr
+ r-dt
+ r-forcats
+ r-ggplot2
+ r-glmnet
+ r-gunifrac
+ r-lattice
+ r-limma
+ r-magrittr
+ r-matrix
+ r-multiassayexperiment
+ r-plotly
+ r-plotroc
+ r-rentrez
+ r-reshape2
+ r-s4vectors
+ r-scales
+ r-shiny
+ r-shinyjs
+ r-summarizedexperiment
+ r-tibble
+ r-tsne
+ r-umap
+ r-vegan
+ r-xml))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/compbiomed/animalcules")
+ (synopsis "Interactive microbiome analysis toolkit")
+ (description
+ "Animalcules is an R package for utilizing up-to-date data analytics,
+visualization methods, and machine learning models to provide users an
+easy-to-use interactive microbiome analysis framework. It can be used as a
+standalone software package or users can explore their data with the
+accompanying interactive R Shiny application. Traditional microbiome analysis
+such as alpha/beta diversity and differential abundance analysis are enhanced,
+while new methods like biomarker identification are introduced by animalcules.
+Powerful interactive and dynamic figures generated by animalcules enable users
+to understand their data better and discover new insights.")
+ (license license:artistic2.0)))
+
(define-public r-aldex2
(package
(name "r-aldex2")
@@ -2492,6 +2598,37 @@ mapped reads). It is currently designed for un-stranded paired-end RNA-seq
data.")
(license license:gpl2+)))
+(define-public r-altcdfenvs
+ (package
+ (name "r-altcdfenvs")
+ (version "2.60.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "altcdfenvs" version))
+ (sha256
+ (base32
+ "0fm4l93j6nm1w1w57zzryc1hkzapp8l16pkwjzdzllvwvsnsg8r0"))))
+ (properties `((upstream-name . "altcdfenvs")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-affy
+ r-biobase
+ r-biocgenerics
+ r-biostrings
+ r-hypergraph
+ r-makecdfenv
+ r-s4vectors))
+ (home-page "https://bioconductor.org/packages/altcdfenvs")
+ (synopsis
+ "Convenience data structures and functions to handle CDF environments")
+ (description
+ "The package is usable with Affymetrix GeneChip short oligonucleotide
+arrays, and it can be adapted or extended to other platforms. It is able to
+modify or replace the grouping of probes in the probe sets. Also, the package
+contains simple functions to read R connections in the FASTA format and it can
+create an alternative mapping from sequences.")
+ (license license:gpl2+)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")
@@ -2720,6 +2857,40 @@ biological knowledge. Genes, and clinical pathways are incorporated in the
model as latent variables.")
(license license:gpl3)))
+(define-public r-asics
+ (package
+ (name "r-asics")
+ (version "2.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ASICS" version))
+ (sha256
+ (base32
+ "0c2b3gdza58vqhharhw8967p2w2knnrm5s2svvnnjbf67qbg45b7"))))
+ (properties `((upstream-name . "ASICS")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocparallel
+ r-ggplot2
+ r-glmnet
+ r-gridextra
+ r-matrix
+ r-mvtnorm
+ r-pepsnmr
+ r-plyr
+ r-quadprog
+ r-ropls
+ r-summarizedexperiment
+ r-zoo))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/ASICS")
+ (synopsis "Automatic statistical identification in complex spectra")
+ (description
+ "ASICS quantifies concentration of metabolites in a complex spectrum.
+The identification of metabolites is performed by fitting a mixture model to
+the spectra of the library with a sparse penalty.")
+ (license license:gpl2+)))
+
(define-public r-aspli
(package
(name "r-aspli")
@@ -3121,13 +3292,13 @@ Various visual and textual types of output are available.")
(define-public r-bambu
(package
(name "r-bambu")
- (version "3.0.2")
+ (version "3.0.5")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "bambu" version))
(sha256
(base32
- "0246cn5l1kxysjrzy4prfdxn71vc47a8kciqw384nm2mi3vsy4vx"))))
+ "12rcbspy4ly714cyxbgd5v2m92vasksxm19m6hd4avasrhcr4d6l"))))
(properties `((upstream-name . "bambu")))
(build-system r-build-system)
(propagated-inputs
@@ -3164,13 +3335,13 @@ usage.")
(define-public r-bandits
(package
(name "r-bandits")
- (version "1.14.0")
+ (version "1.14.1")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "BANDITS" version))
(sha256
(base32
- "18xq8gg1j07gbbxy7r0cc34zwn40mh4fr39zzi8l3z0cymw73qs8"))))
+ "0dbiz7zgdl3bqrwf4ffb73sc2dd8ygh76fakx5887a14azj8pk8x"))))
(properties `((upstream-name . "BANDITS")))
(build-system r-build-system)
(propagated-inputs
@@ -3309,6 +3480,44 @@ of Bioconductor.")
packages.")
(license license:artistic2.0)))
+(define-public r-cardelino
+ (package
+ (name "r-cardelino")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "cardelino" version))
+ (sha256
+ (base32
+ "1ma4clkrkrjvy12ln2d2smyzzsz9y9554f5wgwmh9kv6s4xc66qs"))))
+ (properties `((upstream-name . "cardelino")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-combinat
+ r-genomeinfodb
+ r-genomicranges
+ r-ggplot2
+ r-ggtree
+ r-matrix
+ r-matrixstats
+ r-pheatmap
+ r-s4vectors
+ r-snpstats
+ r-variantannotation
+ r-vcfr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/single-cell-genetics/cardelino")
+ (synopsis "Clone identification from single cell data")
+ (description
+ "This package provides methods to infer clonal tree configuration for a
+population of cells using single-cell RNA-seq data (scRNA-seq), and possibly
+other data modalities. Methods are also provided to assign cells to inferred
+clones and explore differences in gene expression between clones. These
+methods can flexibly integrate information from imperfect clonal trees
+inferred based on bulk exome-seq data, and sparse variant alleles expressed in
+scRNA-seq data. A flexible beta-binomial error model that accounts for
+stochastic dropout events as well as systematic allelic imbalance is used.")
+ (license license:gpl3)))
+
(define-public r-coverageview
(package
(name "r-coverageview")
@@ -3391,13 +3600,13 @@ factorial microarray data.")
(define-public r-damefinder
(package
(name "r-damefinder")
- (version "1.10.0")
+ (version "1.10.1")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "DAMEfinder" version))
(sha256
(base32
- "0ygsgg51473sycsh367rf8plca6zb1jg2l39zcprwvgpiln8mjdg"))))
+ "1cgykb70mxnhilwwp1jr4dr523zvjxpix173s4ldfh49064gzwc1"))))
(properties `((upstream-name . "DAMEfinder")))
(build-system r-build-system)
(propagated-inputs
@@ -3705,13 +3914,13 @@ negative control samples.")
(define-public r-deconvr
(package
(name "r-deconvr")
- (version "1.4.2")
+ (version "1.4.3")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "deconvR" version))
(sha256
(base32
- "1wa8l9zxdwx32122slnzqyk32klyznxnbziwn98jbp5fxmjka92l"))))
+ "1jz7q4rv3m85bcvarjhqsyc2330fynb0wr5ajd2qffznczk846xb"))))
(properties `((upstream-name . "deconvR")))
(build-system r-build-system)
(propagated-inputs
@@ -3727,6 +3936,7 @@ negative control samples.")
r-mass
r-matrixstats
r-methylkit
+ r-minfi
r-nnls
r-quadprog
r-rsq
@@ -4787,13 +4997,13 @@ only one command.")
(define-public r-biocparallel
(package
(name "r-biocparallel")
- (version "1.32.3")
+ (version "1.32.4")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "BiocParallel" version))
(sha256
(base32
- "0z2g3p6ip4g865na9bmqaa7w2s52769pmjr3hpiv6x8bhifh3nm5"))))
+ "1m4i27zx3ajwygwp38lrxf36rs575dkaxxc6jawpj1kzn7whi5ym"))))
(properties
`((upstream-name . "BiocParallel")))
(build-system r-build-system)
@@ -5154,26 +5364,26 @@ distribution.")
(define-public r-deseq2
(package
(name "r-deseq2")
- (version "1.38.1")
+ (version "1.38.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "DESeq2" version))
(sha256
(base32
- "0xp3rfhwn8k1bqzqnjzjqlaq8lqyad7kqjhb29vkbxgzjvafvxmk"))))
+ "1m81yvcl63h5m7kbbxpjk7hzygxmn4l9mlgqrdmnnls56183h3b4"))))
(properties `((upstream-name . "DESeq2")))
(build-system r-build-system)
(propagated-inputs
(list r-biobase
r-biocgenerics
r-biocparallel
- r-genefilter
r-geneplotter
r-genomicranges
r-ggplot2
r-iranges
r-locfit
+ r-matrixstats
r-rcpp
r-rcpparmadillo
r-s4vectors
@@ -5386,13 +5596,13 @@ global-scaling and full-quantile normalization.")
(define-public r-edger
(package
(name "r-edger")
- (version "3.40.0")
+ (version "3.40.1")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "edgeR" version))
(sha256
(base32
- "18vap3qp9blncr4sdl9q1szb4qhm46gldhxy3k3abw9fckcvggwg"))))
+ "1a0rmczlqmqmip2ix28m4iwcpfj04p6nrcl562bjgaifvgyjqhzg"))))
(properties `((upstream-name . "edgeR")))
(build-system r-build-system)
(propagated-inputs
@@ -5511,14 +5721,14 @@ analysis using other methods.")
(define-public r-genefilter
(package
(name "r-genefilter")
- (version "1.80.0")
+ (version "1.80.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "genefilter" version))
(sha256
(base32
- "0swdqdyz956gx44crbx3qai0qx7n7yazg3yw7i93djcgahyz3kk7"))))
+ "0f25z0hqmrkimv14j03pgjsxpq5rz9ymk151rlg4j4vpc06n73cq"))))
(build-system r-build-system)
(native-inputs
(list gfortran r-knitr))
@@ -5601,13 +5811,13 @@ genomic intervals. In addition, it can use BAM or BigWig files as input.")
(define-public r-genomeinfodb
(package
(name "r-genomeinfodb")
- (version "1.34.3")
+ (version "1.34.4")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "GenomeInfoDb" version))
(sha256
(base32
- "1pw8ml6b33z7zh7h592xl23l8dy32nqq4lzq20p57n9f0krqj1iv"))))
+ "1nskqmlar85zg96c1fbacl7dqg6r0gl814rc7yh482y4wgmwyg0r"))))
(properties
`((upstream-name . "GenomeInfoDb")))
(build-system r-build-system)
@@ -5661,13 +5871,13 @@ alignments.")
(define-public r-genomicfeatures
(package
(name "r-genomicfeatures")
- (version "1.50.2")
+ (version "1.50.3")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "GenomicFeatures" version))
(sha256
(base32
- "10w15j107hy9qb0lh6jmyw7rinfvy3ca34xsskxw3wf25mh6vhzz"))))
+ "14pn7lngayascj5k84g2g748assbivpiakss247cdj9ngzx5sfwz"))))
(properties
`((upstream-name . "GenomicFeatures")))
(build-system r-build-system)
@@ -5739,13 +5949,13 @@ provide added flexibility for data combination and manipulation.")
(define-public r-genomicranges
(package
(name "r-genomicranges")
- (version "1.50.1")
+ (version "1.50.2")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "GenomicRanges" version))
(sha256
(base32
- "14m4pvvd9m8kpc7k905km9vib7giq0i9g11bxc1ygw30ifi96966"))))
+ "13b6bm6nrxx1vgzrzpf59c2lq5w8kjq9hsch5h037f0p9w3w5z9p"))))
(properties
`((upstream-name . "GenomicRanges")))
(build-system r-build-system)
@@ -5823,6 +6033,33 @@ testing and other simple calculations.")
Enrichment Analysis} (GSEA).")
(license license:artistic2.0)))
+(define-public r-harshlight
+ (package
+ (name "r-harshlight")
+ (version "1.70.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Harshlight" version))
+ (sha256
+ (base32
+ "0asjgcnwawg8x7ql0srhb2011rvb4kr2cpsa1cy28nfmjfvdf0qm"))))
+ (properties `((upstream-name . "Harshlight")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-affy
+ r-altcdfenvs
+ r-biobase))
+ (home-page "http://asterion.rockefeller.edu/Harshlight/")
+ (synopsis "Corrective make-up program for microarray chips")
+ (description
+ "The package detects extended diffuse and compact blemishes on microarray
+chips. Harshlight marks the areas in a collection of chips (affybatch
+objects). A corrected @code{AffyBatch} object will result. The package
+replaces the defected areas with @code{N/A}s or the median of the values of
+the same probe. The new version handles the substitute value as a whole
+matrix to solve the memory problem.")
+ (license license:gpl2+)))
+
(define-public r-hpar
(package
(name "r-hpar")
@@ -5875,13 +6112,13 @@ of other R packages who wish to make use of HTSlib.")
(define-public r-impute
(package
(name "r-impute")
- (version "1.72.1")
+ (version "1.72.2")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "impute" version))
(sha256
(base32
- "0862mpbmznizcq5bgnp85dl9q0bip76jkga45gssdrv90wsi2192"))))
+ "1k697pqlkrwmfszipl9irbzmwhk1vz97j3rh0k5nj2mrj3dr71mv"))))
(native-inputs
(list gfortran))
(build-system r-build-system)
@@ -5944,13 +6181,13 @@ Shiny-based display methods for Bioconductor objects.")
(define-public r-lfa
(package
(name "r-lfa")
- (version "1.28.0")
+ (version "1.28.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "lfa" version))
(sha256
- (base32 "1l3ip0bsvbz9nagzv47qjh5hf7qf8ffk4hlnkwagngiwyq84vyp1"))))
+ (base32 "0047wspvarbnbawrwvfjfz5y6i36l2r2k2501zjya09rjpiq101m"))))
(properties `((upstream-name . "lfa")))
(build-system r-build-system)
(propagated-inputs (list r-corpcor))
@@ -6010,6 +6247,33 @@ reduction (between group analysis) and joint dimension reduction of two
datasets (coinertia analysis).")
(license license:artistic2.0)))
+(define-public r-makecdfenv
+ (package
+ (name "r-makecdfenv")
+ (version "1.74.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "makecdfenv" version))
+ (sha256
+ (base32
+ "0bvj5dg6yfjnhga1z8788zmb98d8shyz8pzz0ggnml87c1p2gy25"))))
+ (properties `((upstream-name . "makecdfenv")))
+ (build-system r-build-system)
+ (inputs (list zlib))
+ (propagated-inputs
+ (list r-affy
+ r-affyio
+ r-biobase
+ r-zlibbioc))
+ (home-page "https://bioconductor.org/packages/makecdfenv")
+ (synopsis "Chip description file environment maker")
+ (description
+ "This package implements two functions. One of them reads an Affymetrix
+@acronym{CDF, chip description file} and creates a hash table environment
+containing the location/probe set membership mapping. The other one creates a
+package that automatically loads that environment.")
+ (license license:gpl2+)))
+
(define-public r-metaneighbor
(package
(name "r-metaneighbor")
@@ -7050,13 +7314,13 @@ comprehensive scDblFinder method.")
(define-public r-scmap
(package
(name "r-scmap")
- (version "1.20.0")
+ (version "1.20.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "scmap" version))
(sha256
- (base32 "14vyjvfs2n4h0xsy25xg4zdmc8dqbg5vyl3qns6f0rh4bsshqdlm"))))
+ (base32 "0rq185ynk874vgw4a5s2n92381dj6kxxnx2fcx2v7b2ahr3ybys7"))))
(properties `((upstream-name . "scmap")))
(build-system r-build-system)
(propagated-inputs
@@ -7597,13 +7861,13 @@ dependencies between GO terms can be implemented and applied.")
(define-public r-tximport
(package
(name "r-tximport")
- (version "1.26.0")
+ (version "1.26.1")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "tximport" version))
(sha256
(base32
- "1w1m6r85a5nvcfxbkq5dmczaar8vf3vbrgrmxqkjqhlpcq58z5ng"))))
+ "1r67q4nb2bx9nqycyr2gnfmh4gizl0c7l510vmlcdvplv3yi73yn"))))
(build-system r-build-system)
(native-inputs
(list r-knitr))
@@ -7970,14 +8234,14 @@ packages.")
(define-public r-oligo
(package
(name "r-oligo")
- (version "1.62.0")
+ (version "1.62.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "oligo" version))
(sha256
(base32
- "0l6yb58frh4c080k6h8wyipc5kiz4qi7jimnr62jg8d737rrvnk2"))))
+ "1rhzav57d092ip9qjsmskj3l8h4xyq8cpa2a2jl8g32fwh0dyvsz"))))
(properties `((upstream-name . "oligo")))
(build-system r-build-system)
(inputs (list zlib))
@@ -8115,14 +8379,14 @@ signal in the input, that lead to spurious peaks during peak calling.")
(define-public r-diffbind
(package
(name "r-diffbind")
- (version "3.8.1")
+ (version "3.8.3")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "DiffBind" version))
(sha256
(base32
- "1wgnrd1xpl49pdxxjzzl0v9535naapwp3ayqzvrx3z4m6iai2awj"))))
+ "039gy9ll6ingh3y5h2hp3rhbh2imaryjxzgf8ysk87irlbpnx1qs"))))
(properties `((upstream-name . "DiffBind")))
(build-system r-build-system)
(propagated-inputs
@@ -8323,6 +8587,35 @@ classification and ranking tasks. @dfn{Area under curve} (AUC), precision at
a given recall, F-score for single and multiple classes are available.")
(license license:gpl2+)))
+(define-public r-pepsnmr
+ (package
+ (name "r-pepsnmr")
+ (version "1.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "PepsNMR" version))
+ (sha256
+ (base32
+ "02i29jinawssqlb33wvj0h9w6cfcvamlyfxdynd38jmwx23l15l5"))))
+ (properties `((upstream-name . "PepsNMR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ggplot2
+ r-gridextra
+ r-matrix
+ r-matrixstats
+ r-ptw
+ r-reshape2))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/ManonMartin/PepsNMR")
+ (synopsis "Pre-process 1H-NMR FID signals")
+ (description
+ "This package provides R functions for common pre-processing steps that
+are applied on @acronym{1H-NMR, proton nuclear magnetic resonance} data. It
+also provides a function to read the @acronym{FID, free induction decay}
+signals directly in the Bruker format.")
+ (license license:gpl2)))
+
;; This is a CRAN package, but it depends on a Bioconductor package.
(define-public r-codedepends
(package
@@ -8804,13 +9097,13 @@ information.")
(define-public r-glmgampoi
(package
(name "r-glmgampoi")
- (version "1.10.0")
+ (version "1.10.1")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "glmGamPoi" version))
(sha256
(base32
- "12jbqigg4k2ngrk2anbrrxrwkp57bbzdz492lg8lc6w1gygp5yip"))))
+ "1qxzbh5i208cpghmysailachj8xpx4g4iqk8552xjpjkn54pkpbd"))))
(properties `((upstream-name . "glmGamPoi")))
(build-system r-build-system)
(propagated-inputs
@@ -9331,14 +9624,14 @@ penalized least squares regression method.")
(define-public r-dnacopy
(package
(name "r-dnacopy")
- (version "1.72.0")
+ (version "1.72.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "DNAcopy" version))
(sha256
(base32
- "0z2hl68f5f6d2w6gbhax4531g3zbgiihj99h32sa44hp29al38ld"))))
+ "1f6ilfwhli7bdnr48y2ijdydvw7kjbyz701kgbsw3w7inr6x6ayr"))))
(properties `((upstream-name . "DNAcopy")))
(build-system r-build-system)
(native-inputs (list gfortran))
@@ -9489,14 +9782,14 @@ coordinates.")
(define-public r-lpsymphony
(package
(name "r-lpsymphony")
- (version "1.26.0")
+ (version "1.26.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "lpsymphony" version))
(sha256
(base32
- "0ryl48zxscb35s1gizyspxg48dlqg1j51h9iw2flq16y7y63ppzi"))))
+ "167zpf7k7gn7gw2cxkqx89y322qinyzjr1naracp5axj4q2qagm3"))))
(build-system r-build-system)
(arguments
(list
@@ -10378,14 +10671,14 @@ especially Illumina Infinium methylation microarrays.")
(define-public r-linnorm
(package
(name "r-linnorm")
- (version "2.22.0")
+ (version "2.22.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "Linnorm" version))
(sha256
(base32
- "0ndhvdd9gkqyayxqgj5320sgj15di7ji945lpdi3rj5lwldh7na0"))))
+ "16d7viyidqbsy3mbr2cpq9p291yf362a4blhvs05qxcwm3fjllij"))))
(properties `((upstream-name . "Linnorm")))
(build-system r-build-system)
(propagated-inputs
@@ -10726,14 +11019,14 @@ the data set is suitable for such analysis.")
(define-public r-sigpathway
(package
(name "r-sigpathway")
- (version "1.66.0")
+ (version "1.66.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "sigPathway" version))
(sha256
(base32
- "0vb6v61ak8z3hx7d65lr1hrxk89n36j0zi3x0pp828khdyh3zvag"))))
+ "1ln1n4zwmjw1ils45vix93q3h19xlg4q894yhhxkphgyj0qcy00b"))))
(properties `((upstream-name . "sigPathway")))
(build-system r-build-system)
(home-page "https://www.pnas.org/cgi/doi/10.1073/pnas.0506577102")
@@ -10848,14 +11141,14 @@ data.")
(define-public r-enrichplot
(package
(name "r-enrichplot")
- (version "1.18.1")
+ (version "1.18.3")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "enrichplot" version))
(sha256
(base32
- "1x84wlkqisq1x2zniy4mp02zlsp4v85kxbflalmq0pixlkagq0vr"))))
+ "0nzcr23m58z3h0n0frxf26z14j7ilcl4fjy7rqm7f2i1wyld70zl"))))
(build-system r-build-system)
(propagated-inputs
(list r-aplot
@@ -10926,13 +11219,13 @@ profiles (GO and KEGG) of gene and gene clusters.")
(define-public r-clusterexperiment
(package
(name "r-clusterexperiment")
- (version "2.18.0")
+ (version "2.18.1")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "clusterExperiment" version))
(sha256
(base32
- "04kdiwz8qzr7cr1an1c7a684wqv9pkca0iaym5f069pdjhqvvq0a"))))
+ "1f3f56d88yiqyj45rhcwqb04wbxr9m4fxhbbckw1j7nykm8100ps"))))
(build-system r-build-system)
(native-inputs
(list r-knitr))
@@ -11695,14 +11988,14 @@ investigation using RNA-seq data.")
(define-public r-aucell
(package
(name "r-aucell")
- (version "1.20.1")
+ (version "1.20.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "AUCell" version))
(sha256
(base32
- "0bq729kavqkam2s4dmfzixgznsys61j0lvj5pk3b70gxv44gmpsh"))))
+ "1qb13qd5xzgrpx6jlg3ll0ff5spz3y06ji31vvqzm759almg2w3s"))))
(properties `((upstream-name . "AUCell")))
(build-system r-build-system)
(propagated-inputs
@@ -11711,6 +12004,7 @@ investigation using RNA-seq data.")
r-delayedarray
r-delayedmatrixstats
r-gseabase
+ r-matrix
r-mixtools
r-r-utils
r-shiny
@@ -12531,14 +12825,14 @@ and data files used across sessions.")
(define-public r-iclusterplus
(package
(name "r-iclusterplus")
- (version "1.34.0")
+ (version "1.34.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "iClusterPlus" version))
(sha256
(base32
- "01bl1gmc1v1b4lh88sdazjvm8pl7383dgzxnhmzpxwz7lkcxi1h2"))))
+ "05y4jmbf8sxl32f3g5lw9ycxky0rw69gax3n2z0kif7xcb5qf3qv"))))
(properties `((upstream-name . "iClusterPlus")))
(build-system r-build-system)
(native-inputs (list gfortran))
@@ -12971,14 +13265,14 @@ annotations.")
(define-public r-rsubread
(package
(name "r-rsubread")
- (version "2.12.0")
+ (version "2.12.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "Rsubread" version))
(sha256
(base32
- "0iha7xln7l3mrmka8rcmmlp74f5km9rc88k9nv6bxw0krr03089n"))))
+ "1gvd8vmglvzc3bixqxrm4k7yikl2as5l4x6bvvvnwsgx2i7vz7dm"))))
(properties `((upstream-name . "Rsubread")))
(build-system r-build-system)
(inputs (list zlib))
@@ -13204,14 +13498,14 @@ manipulation of flow cytometry data.")
(define-public r-ggcyto
(package
(name "r-ggcyto")
- (version "1.26.0")
+ (version "1.26.4")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "ggcyto" version))
(sha256
(base32
- "0phhm54wcqihj62a0jk46whmf6wwg7wj3306wvnszy7yik4z857w"))))
+ "1pj1v0bhvckvwn1p826phskqz9lv71c1913cz5w0fd87dzdbpzpj"))))
(properties `((upstream-name . "ggcyto")))
(build-system r-build-system)
(propagated-inputs
@@ -13427,38 +13721,30 @@ package.")
(define-public r-opencyto
(package
(name "r-opencyto")
- (version "2.10.0")
+ (version "2.10.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "openCyto" version))
(sha256
(base32
- "1pkpm98fs17zqdvyymd58sl4cib7gdi7drvdkagilrafjcrpq31m"))))
+ "16wsa9dhnz8gz1siyhfxvnbfg142g7fmhxiqxr7n69qpq9w8yhr0"))))
(properties `((upstream-name . "openCyto")))
(build-system r-build-system)
(propagated-inputs
- (list r-biobase
+ (list r-bh
+ r-biobase
r-biocgenerics
- r-clue
+ r-cpp11
r-data-table
r-flowclust
r-flowcore
- r-flowstats
r-flowviz
r-flowworkspace
r-graph
- r-gtools
- r-ks
- r-lattice
- r-mass
r-ncdfflow
- r-plyr
- r-r-utils
r-rbgl
- r-rcolorbrewer
- r-rcpp
- r-rrcov))
+ r-rcolorbrewer))
(native-inputs
(list r-knitr))
(home-page "https://bioconductor.org/packages/openCyto")
@@ -13658,14 +13944,14 @@ data, to only emphasize the data that actually matters.")
(define-public r-rcistarget
(package
(name "r-rcistarget")
- (version "1.17.0")
+ (version "1.18.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "RcisTarget" version))
(sha256
(base32
- "1anwin5476q2n0zgywrmp3nj6sgy07i6pw1lczydvn4h1a8n1rvk"))))
+ "02lz2m2zhwy1dvmjvlss6qg0dh574qhnvn7al3wx7ck1hkz0dgi2"))))
(properties `((upstream-name . "RcisTarget")))
(build-system r-build-system)
(propagated-inputs
@@ -15328,13 +15614,13 @@ functionality.")
(define-public r-biocviews
(package
(name "r-biocviews")
- (version "1.66.0")
+ (version "1.66.1")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "biocViews" version))
(sha256
(base32
- "1rgn0agw5m4y8838lxzq1r658h1pblaidmm444yfimjffa8znj23"))))
+ "1xplkzm29v6aysfhb6kf2nnmvc37jmcvv6vsgbx8z8qccn96jk02"))))
(properties
`((upstream-name . "biocViews")))
(build-system r-build-system)
@@ -15346,6 +15632,7 @@ functionality.")
r-rcurl
r-xml
r-runit))
+ (native-inputs (list r-knitr))
(home-page "https://bioconductor.org/packages/biocViews")
(synopsis "Bioconductor package categorization helper")
(description "The purpose of biocViews is to create HTML pages that
@@ -15914,14 +16201,14 @@ generated.")
(define-public r-preprocesscore
(package
(name "r-preprocesscore")
- (version "1.60.0")
+ (version "1.60.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "preprocessCore" version))
(sha256
(base32
- "1l0m591scln024jdpib47fndhx2wfp9jgkj3mdmwd9nkc5y0qjda"))))
+ "1rwr31jp4dh3xcfx1kx8rz5xvyx1mrwy85hqrjrfr4m6h0qv28k1"))))
(properties
`((upstream-name . "preprocessCore")))
(build-system r-build-system)
@@ -15935,13 +16222,13 @@ routines.")
(define-public r-s4vectors
(package
(name "r-s4vectors")
- (version "0.36.0")
+ (version "0.36.1")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "S4Vectors" version))
(sha256
(base32
- "05al4diwdbsa9b37i8msxnp79fxk7k24dk2vhh131s3snb89jvfs"))))
+ "16lssnmhy3klqp4sw1328f38cixkjh9317gdyikcrmsbcwg2ak6v"))))
(properties
`((upstream-name . "S4Vectors")))
(build-system r-build-system)
@@ -16425,13 +16712,13 @@ This package wraps C++ code from the MOODS motif calling library.")
(define-public r-chromvar
(package
(name "r-chromvar")
- (version "1.20.0")
+ (version "1.20.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "chromVAR" version))
(sha256
- (base32 "1rwgbicbmszdkr05ksxfsisyhk0a4pvc3jrxbzjyc13jj5h6m5kp"))))
+ (base32 "1nhhpqhpvmw6b0nwxdwsjnakmfpxzpii8fmabwwg9bk8ni3zj5dq"))))
(properties `((upstream-name . "chromVAR")))
(build-system r-build-system)
(propagated-inputs
@@ -16532,14 +16819,14 @@ cell types to infer the cell of origin of each single cell independently.")
(define-public r-scuttle
(package
(name "r-scuttle")
- (version "1.8.1")
+ (version "1.8.3")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "scuttle" version))
(sha256
(base32
- "10wk46zgi57m9q9ab6wlmljcss3fph2r9yp1bp01s9yv7sd749b2"))))
+ "1wgh28rj8m5dz89s9y4rzfy68d8ign6pcnnwj9g7h4sc3jfsg56i"))))
(properties `((upstream-name . "scuttle")))
(build-system r-build-system)
(propagated-inputs
@@ -16612,14 +16899,14 @@ quality control.")
(define-public r-scran
(package
(name "r-scran")
- (version "1.26.0")
+ (version "1.26.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "scran" version))
(sha256
(base32
- "11iwpw44600pfx01vqil97k728m1wf4dljr27k2ak4s7z75kxfih"))))
+ "1sqc8pf1qzm24kf1l45da12wbzv0nxsy6l3v9fc8srmnvk37p04p"))))
(build-system r-build-system)
(propagated-inputs
(list r-beachmat
@@ -17214,13 +17501,13 @@ EMBL-EBI GWAS catalog.")
(define-public r-kegggraph
(package
(name "r-kegggraph")
- (version "1.58.0")
+ (version "1.58.3")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "KEGGgraph" version))
(sha256
- (base32 "0hpsb009qmhy9p67d5wd0cl60smhgjlhxsz5f52i1c6qy4jk1niq"))))
+ (base32 "1s5j7zdp8ck4vhca81i4b6qclhwi56gmz8brawrxj3szvwmxf3y6"))))
(properties `((upstream-name . "KEGGgraph")))
(build-system r-build-system)
(propagated-inputs