summaryrefslogtreecommitdiff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm21
1 files changed, 17 insertions, 4 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index 26c0cf4332..a86984b28c 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Jonathan Brielmaier <[email protected]>
;;; Copyright © 2020 Jakub Kądziołka <[email protected]>
;;; Copyright © 2020 Noah Landis <[email protected]>
+;;; Copyright © 2021 Sergiu Ivanov <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -202,10 +203,10 @@ dictionaries, including personal ones.")
(define-public aspell-dict-en
(aspell-dictionary "en" "English"
- #:version "2019.10.06-0"
+ #:version "2020.12.07-0"
#:sha256
(base32
- "1zai9wrqwgb9z9vfgb22qhrvxvg73jg0ix44j1khm2f6m96lncr4")))
+ "1cwzqkm8gr1w51rpckwlvb43sb0b5nbwy7s8ns5vi250515773sc")))
(define-public aspell-dict-eo
(aspell-dictionary "eo" "Esperanto"
@@ -356,6 +357,14 @@ dictionaries, including personal ones.")
(base32
"137i4njvnslab6l4s291s11xijr5jsy75lbdph32f9y183lagy9m")))
+(define-public aspell-dict-ro
+ (aspell-dictionary "ro" "Romanian"
+ #:version "3.3-2"
+ #:prefix "aspell5-"
+ #:sha256
+ (base32
+ "0gb8j9iy1acdl11jq76idgc2lbc1rq3w04favn8cyh55d1v8phsk")))
+
;;;
;;; Hunspell packages made from the Aspell word lists.
@@ -388,6 +397,10 @@ dictionaries, including personal ones.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-reproducible
+ (lambda _
+ (substitute* "speller/README_en.txt.sh"
+ (("\\bdate\\b") ""))))
(delete 'configure)
(delete 'check)
(replace 'build
@@ -476,14 +489,14 @@ under permissive licensing terms. See the 'Copyright' file."))))
(define-public ispell
(package
(name "ispell")
- (version "3.4.02")
+ (version "3.4.04")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.cs.hmc.edu/~geoff/tars/ispell-"
version ".tar.gz"))
(sha256
- (base32 "0b6rqzqjdhwf323sf1dv8qzx5pxa5asz618922r59zjp65660yb6"))))
+ (base32 "0gp1rwn8grkvz28wgisc2j9w9svldnaiahl3lyis118xabqddg47"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-build? #f