summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/wm.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index b6c59010a8..1da2e752ff 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -49,7 +49,7 @@
;;; Copyright © 2021, 2022 Petr Hodina <[email protected]>
;;; Copyright © 2021, 2023 jgart <[email protected]>
;;; Copyright © 2021 Disseminate Dissent <[email protected]>
-;;; Copyright © 2022 John Kehayias <[email protected]>
+;;; Copyright © 2022, 2025 John Kehayias <[email protected]>
;;; Copyright © 2022 Gabriel Wicki <[email protected]>
;;; Copyright © 2022 Jai Vetrivelan <[email protected]>
;;; Copyright © 2022 Daniel Meißner <[email protected]>
@@ -324,6 +324,36 @@ or musca).
(home-page "https://herbstluftwm.org")
(license license:bsd-2)))
+(define-public hypridle
+ (package
+ (name "hypridle")
+ (version "0.1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hyprwm/hypridle")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1622iz8bl8mi7gj2sc2jq6z7622l7l2izj1l9ajwj2mxpwpkdhbs"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f)) ;No tests.
+ (native-inputs (list gcc-13 pkg-config))
+ (inputs
+ (list hyprlang
+ hyprutils
+ sdbus-c++
+ wayland
+ wayland-protocols))
+ (home-page "https://github.com/hyprwm/hypridle")
+ (synopsis "Hyprland's idle daemon")
+ (description
+ "Hyprland's idle daemon, based on the @code{ext-idle-notify-v1} Wayland
+protocol. Hypridle has support for D-Bus's loginctl
+commands (lock/unlock/before-sleep) and inhibit.")
+ (license license:bsd-3)))
+
(define-public hyprland
(package
(name "hyprland")