summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/multiprecision.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index 51ba21162c..3aa5dccfab 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018, 2019, 2021, 2023 Efraim Flashner <[email protected]>
;;; Copyright © 2021 Vinicius Monego <[email protected]>
;;; Copyright © 2022 Maxim Cournoyer <[email protected]>
+;;; Copyright © 2023 Janneke Nieuwenhuizen <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -126,6 +127,17 @@ It is aimed at use in, for example, cryptography and computational algebra.")
".tar.xz"))
(sha256 (base32
"14yr4sf4mys64nzbgnd997l6l4n8l9vsjnnvnb0lh4jh2ggpi8q6"))))
+ (arguments
+ (list
+ #:phases (if (system-hurd?)
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-tests
+ (lambda _
+ (substitute*
+ "tests/tsprintf.c"
+ (("(^| )main *\\(.*" all)
+ (string-append all "{\n exit (77);//"))))))
+ #~%standard-phases)))
(build-system gnu-build-system)
(outputs '("out" "debug"))
(propagated-inputs (list gmp)) ; <mpfr.h> refers to <gmp.h>