summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnome.scm32
-rw-r--r--gnu/packages/guile-xyz.scm2
-rw-r--r--gnu/packages/lxde.scm2
-rw-r--r--gnu/packages/mate.scm2
-rw-r--r--gnu/packages/pantheon.scm2
-rw-r--r--gnu/packages/spice.scm2
-rw-r--r--gnu/packages/sugar.scm2
-rw-r--r--gnu/packages/terminals.scm8
-rw-r--r--gnu/packages/virtualization.scm2
-rw-r--r--gnu/packages/vnc.scm2
-rw-r--r--gnu/packages/xfce.scm2
11 files changed, 30 insertions, 28 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8d53342ae7..a44007307f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1291,7 +1291,7 @@ in particular in the GNOME desktop.")
libxrandr
libxtst
libxxf86vm
- vte
+ vte/gtk+-3
xorgproto))
(synopsis "Color profile manager for the GNOME desktop")
(description "GNOME Color Manager is a session framework that makes
@@ -4654,7 +4654,9 @@ targeting the GNOME stack simple.")
(build-system meson-build-system)
(arguments
(list #:configure-flags #~(list "-Dvapi=true"
- "-D_systemd=false")))
+ "-D_systemd=false"
+ "-Dgtk4=true"
+ "-Dgtk3=false")))
(native-inputs
(list pkg-config
gettext-minimal
@@ -4665,9 +4667,9 @@ targeting the GNOME stack simple.")
python
libxml2))
(propagated-inputs
- (list gtk+ ; required by vte-2.91.pc
- gnutls ; ditto
- pcre2)) ; ditto
+ (list gtk ; required by vte-2.91.pc
+ gnutls ; ditto
+ pcre2)) ; ditto
(home-page "https://www.gnome.org/")
(synopsis "Virtual Terminal Emulator")
(description
@@ -4677,14 +4679,14 @@ gnome-terminal, but can also be used to embed a console/terminal in games,
editors, IDEs, etc.")
(license license:lgpl2.1+)))
-(define-public vte-with-gtk-4
+(define-public vte/gtk+-3
(package/inherit vte
- (name "vte-with-gtk4")
+ (name "vte-with-gtk+3")
(arguments (substitute-keyword-arguments (package-arguments vte)
((#:configure-flags flags #~'())
- #~(cons* "-Dgtk4=true" "-Dgtk3=false" #$flags))))
+ #~(list "-Dvapi=true" "-D_systemd=false"))))
(propagated-inputs (modify-inputs (package-propagated-inputs vte)
- (replace "gtk+" gtk)))))
+ (replace "gtk" gtk+)))))
;; Stable version for gtk2, required by gnurobots and lxterminal as of 2020-07.
(define-public vte/gtk+-2
@@ -4759,7 +4761,7 @@ editors, IDEs, etc.")
spice
spice-gtk
telepathy-glib
- vte))
+ vte/gtk+-3))
(home-page "https://wiki.gnome.org/Apps/Vinagre")
(synopsis "Remote desktop viewer for GNOME")
(description "Vinagre is a remote display client supporting the VNC, SPICE
@@ -5548,7 +5550,7 @@ more fun.")
desktop-file-utils))
(inputs (list gtk
libadwaita
- vte-with-gtk-4
+ vte
libgtop
gsettings-desktop-schemas))
(home-page "https://gitlab.gnome.org/GNOME/console")
@@ -5611,7 +5613,7 @@ org.gnome.ShellSearchProvider2.xml"))))))
nautilus ;for extension
`(,util-linux "lib")
vala
- vte))
+ vte/gtk+-3))
(home-page "https://wiki.gnome.org/Apps/Terminal")
(synopsis "Terminal emulator")
(description
@@ -12309,7 +12311,7 @@ advanced image management tool")
("python-notify2" ,python-notify2)
("python-pycairo" ,python-pycairo)
("python-pygobject" ,python-pygobject)
- ("vte" ,vte)))
+ ("vte" ,vte/gtk+-3)))
(propagated-inputs
(list python-configobj))
(arguments
@@ -12830,7 +12832,7 @@ integrate seamlessly with the GNOME desktop.")
qemu-minimal ;for qemu-img
sparql-query
tracker
- vte
+ vte/gtk+-3
webkitgtk-for-gtk3))
(propagated-inputs
;; Propagating spice-gtk is necessary so that the gnome-desktop-service
@@ -13649,7 +13651,7 @@ libraries. Applications do not need to be recompiled--or even restarted.")
python-pygobject
sysprof
template-glib
- vte-with-gtk-4
+ vte
webkitgtk))
(propagated-inputs
(list gtksourceview)) ;needed for settings
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 7797209a99..1f421983d0 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4849,7 +4849,7 @@ processing filters.")
("webkitgtk" ,webkitgtk-for-gtk3)
("gtksourceview" ,gtksourceview-4)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("vte" ,vte)
+ ("vte" ,vte/gtk+-3)
;; Gstreamer
("gstreamer" ,gstreamer)
("gst-plugins-base" ,gst-plugins-base)
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 1a969eb4b5..904bfa7158 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -198,7 +198,7 @@ toolkit. It allows users to monitor and control of running processes.")
"1124pghrhnx6q4391ri8nvi6bsmvbj1dx81an08mird8jf2b2rii"))))
(build-system gnu-build-system)
(arguments (list #:configure-flags #~(list "--enable-gtk3")))
- (inputs (list gtk+ vte))
+ (inputs (list gtk+ vte/gtk+-3))
(native-inputs (list intltool pkg-config))
(synopsis "LXDE terminal emulator")
(description "LXTerminal is a VTE-based terminal emulator. It supports
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 1ab834b339..b0e9322b76 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -324,7 +324,7 @@ the MATE desktop environment.")
libx11
mate-desktop
pango
- vte))
+ vte/gtk+-3))
(home-page "https://mate-desktop.org/")
(synopsis "MATE Terminal Emulator")
(description
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index adabe6e812..4b3ea8ac0b 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -398,7 +398,7 @@ desktop environment (originally from elementary OS).")
libgee
libhandy
pcre2
- vte))
+ vte/gtk+-3))
(synopsis "Terminal emulator from elementaryOS")
(description "pantheon-terminal is a lightweight, beautiful and simple
terminal. It comes with sane defaults, browser-class tabs, sudo paste
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index d85e7737fd..8c2311aa94 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -422,7 +422,7 @@ share smart cards from client system to local or remote virtual machines.")
libvirt-glib
libxml2
spice-gtk
- vte))
+ vte/gtk+-3))
(synopsis "Graphical console client for virtual machines")
(description "Graphical console client for virtual machines using SPICE or
VNC.")
diff --git a/gnu/packages/sugar.scm b/gnu/packages/sugar.scm
index 5d1bf68650..c95f645212 100644
--- a/gnu/packages/sugar.scm
+++ b/gnu/packages/sugar.scm
@@ -1187,7 +1187,7 @@ not hesitate to feast on the goat.")
;; All these libraries are accessed via gobject introspection.
(propagated-inputs
(list gtk+
- vte
+ vte/gtk+-3
sugar-toolkit-gtk3))
(inputs
(list gettext-minimal))
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 9fdd378cf2..ab11d9bbd4 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -184,7 +184,7 @@ less to gain, as only the helper process is running with privileges (e.g.,
(for-each make-file-writable
(find-files "po" ".")) #t)))))
(native-inputs (list autoconf-2.71 automake gettext-minimal pkg-config))
- (inputs (list libconfuse vte))
+ (inputs (list libconfuse vte/gtk+-3))
(synopsis "GTK+-based drop-down terminal")
(description
"Tilda is a terminal emulator similar to normal terminals like
@@ -947,7 +947,7 @@ a server/client mode.")
(list gettext-minimal perl ; for pod2man
pkg-config))
(inputs
- (list libxft vte))
+ (list libxft vte/gtk+-3))
(home-page "https://launchpad.net/sakura")
(synopsis "Simple but powerful libvte-based terminal emulator")
(description "@code{Sakura} is a terminal emulator based on GTK+ and VTE.
@@ -979,7 +979,7 @@ desktop installed to have a decent terminal emulator.")
#$output))
#:phases #~(modify-phases %standard-phases
(delete 'configure))))
- (inputs (list gtk+ glib vte))
+ (inputs (list gtk+ glib vte/gtk+-3))
(native-inputs (list pkg-config))
(synopsis "Minimalist terminal emulator based on GTK+")
(description
@@ -1460,7 +1460,7 @@ while also supporting native scrolling and @command{tmux} control mode
gtk+
libsecret
libunwind
- vte))
+ vte/gtk+-3))
(native-inputs (list appstream
desktop-file-utils
`(,glib "bin")
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 4d6a527e62..7031caaa08 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1812,7 +1812,7 @@ virtualization library.")
python-requests
qemu
spice-gtk
- vte))
+ vte/gtk+-3))
(native-inputs
(list `(,glib "bin") ; glib-compile-schemas
gobject-introspection
diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index c45f4cab01..bb515ca744 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -159,7 +159,7 @@
libsodium
spice-gtk ; for spice plugin
telepathy-glib
- vte ; for st plugin
+ vte/gtk+-3 ; for st plugin
wayland
webkitgtk-for-gtk3 ; for www plugin
libx11
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 83cede55df..7e17f2497b 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1281,7 +1281,7 @@ features playback of local media files, DVD/CD and live streams.")
(native-inputs
(list docbook-xsl libxslt xfce4-dev-tools))
(inputs
- (list libxfce4ui vte))
+ (list libxfce4ui vte/gtk+-3))
(home-page "https://docs.xfce.org/apps/xfce4-terminal/")
(synopsis "Xfce terminal emulator")
(description